WordPress.org

Ready to get started?Download WordPress

Forums

Using a "192.168.0.x" address (2 posts)

  1. mjchopperboy
    Member
    Posted 1 year ago #

    Hey!
    I just got wordpress but when I try installing it with localhost all of the page links lead to an address starting with localhost, and therefore goes on the visitor's localhost.
    So I tried entering my local address (I only run my website on my intranet, all visitors are from intranet), 192.168.0.18 but it said it couldn't connect.
    I even edited my /etc/hosts to add a new name for 192.168.0.18 but it still said the classic error message.
    What should I do? Thanks

  2. ClaytonJames
    Member
    Posted 1 year ago #

    Change your installation process so that the WordPress addresses in the Dashboard settings contain the internal ip address of the server (and if it isn't a static internal ip address, you're gonna' have a bad time) Then it should be accessible from the LAN. Of course this assumes that you've already made your web server accessible from the LAN, as well.

    If your addresses have "localhost" in them, you've already identified the issue. It can't be properly displayed in any browser other than the one that might be on the machine where it's been installed.

Topic Closed

This topic has been closed to new replies.

About this Topic