WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] Users by Capability won't save (12 posts)

  1. Clifford Paulick
    Member
    Posted 1 year ago #

    In the Users by Capability box, I entered edit_plugins and click to save but it won't save.

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. Clifford Paulick
    Member
    Posted 1 year ago #

    However, it does display the message

    Your settings have been successfully updated.

    after saving.

  3. Clifford Paulick
    Member
    Posted 1 year ago #

    In the Permissions tab, I entered usernames and get this message:

    There was an error updating the following fields: Read access: username not found, Config access: username not found

  4. camu
    Member
    Plugin Author

    Posted 1 year ago #

    I'll take a look at that. It could be a bug. Please remember (see description associated to those fields) that usernames are case SENSITIVE :)

    Cheers
    Camu

  5. Clifford Paulick
    Member
    Posted 1 year ago #

    I think it might have something to do with this:
    Yesterday, I installed an update that screwed up my site. I used WP Engine's restore feature which means the plugin was removed and then also should have been removed from the database, but this wouldn't be the first time it was a weird restore... So maybe clicking the factory reset would clear out the database? Or doing an uninstall and then reinstalling? I don't care about the stats I have in there, just that things are configured properly going forward. Or if you have a list of tables to delete, I can do that in PHPMyAdmin.

    All that to say that I remember setting these options before I clicked to restore the website to the previous state - during which I didn't have these issues of saving properly.

    Sorry for the trouble. Thanks a lot for any suggestions.

  6. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Yep, that must be it, I just tested it on my dev and it worked.

    Factory reset will clean all the tables, but not the settings.

    These are saved in wp_options, in a row whose name is slimstat_options :) Be deleting that row you will reset the default options. See how that goes...

    Camu

  7. Clifford Paulick
    Member
    Posted 1 year ago #

    I deleted that row, but I didn't see if that fixed the problem because I got this buzzkill email from WP Engine so I just deleted the indexes, did the reset, and deleted the plugins.

    Hi Clifford,

    As part of the normal security and performance scans that WP Engine runs on our customer sites, we also scan for plugins that may be on our disallowed plugin list, and adversely affecting site performance and / or security.

    We just scanned your WordPress installation and discovered [wp-slimstat], which is/are on our disallowed list and will result in sub-optimal performance for your site.

    Our policy about plugins we don't allow is here: http://support.wpengine.com/disallowed-plugins/.

    We're sending you this email to request that you remove [wp-slimstat] from your site within the next 7 days. In 7 days, we'll automatically remove those plugins from your site, and we want to give you plenty of time to find and test suitable replacements. For many plugins, we have suggested replacements.

    If you have any questions, please let us know in a support ticket http://wpengine.zendesk.com.

    Thank you,

    -The WP Engine Technical Team

    --
    Automated message from WP Engine.
    Technical Questions? Ask in our Support portal: <http://help.wpengine.com>
    Anything else? Reply to this email or <howdy@wpengine.com>
    http://wpengine.com/
    @wpengine

  8. camu
    Member
    Plugin Author

    Posted 1 year ago #

    What a bummer! Yes, I was aware of some providers out there forbidding their users to install my plugin, because of the space needed to record all the pageviews. My provider, $10/year, doesn't do that to me and gives me 10 GB of DB space. Maybe it's time to look for a different service provider ;)

    Cheers,
    Camu

  9. Clifford Paulick
    Member
    Posted 1 year ago #

    I don't know why this plugin is disallowed, but I won't be switching from WP Engine anytime soon.

    Maybe you could make a lite version that only tracks the pageviews in the database and has a few less options (i.e. database size). However, I'm guessing there are other plugins out there that already do this.

    Thanks anyways. I wish they didn't ban this so I could give it a real trial run for a while.

  10. camu
    Member
    Plugin Author

    Posted 1 year ago #

    There's already plenty of plugins out there that implement simple basic counters ;)

    Camu

  11. frikafrax
    Member
    Posted 1 year ago #

    Hi camu.

    Just want to let you know I'm experiencing this same problem with the "Users By Capability" field not saving.

    I've tried deleting the slimstat_options row then reactivating Slimstat with no luck.

    I tried manually adding this to slimstat_options row:

    "ignore_capabilities";s:16:"activate_plugins";

    But Slimstat still shows a blank field for "Users by Capability."

  12. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, that is a bug that is being addressed in the next version of SlimStat, thank you for pointing it out!

    Camu

    ps: don't forget to vote!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.