WordPress.org

Ready to get started?Download WordPress

Forums

Username Displaying in Author Archive Url (3 posts)

  1. Murray644
    Member
    Posted 1 year ago #

    In my settings menu I have my name to publicly display as Emily, which it does on blog posts but on my author archives it shows my username.

    Now shows:

    mysite.com/author/username

    want it to show:

    mysite.com/author/displayname

    I don't want my username in the url of my archives for obvious reasons.

    One of the first things I was told to do for security purposes was change the user account "admin" to a different name but if anyone can find out my username by looking at my archive url there is still a security breech.

    I don't want to use a plug-in. I would rather add code somewhere to change the user nicename. I tried doing it through my phpmyadmin on my hosting but it messed up my whole site.

    Any ideas?

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Since it is most likely that this issue is related to the author.php template in your theme, and we cannot discern what theme is in use based on your posted info., we can only then ask that you contact your theme dev. for support on how to do this...

  3. Murray644
    Member
    Posted 1 year ago #

    Sorry, I am using Genesis with Crystal Child Theme. I figured it was a WordPress question since username is basic WordPress setting no matter what theme I use.

    Any help greatly appreciated, I really want to take care of it ASAP.

Topic Closed

This topic has been closed to new replies.

About this Topic