WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Username Disappears (4 posts)

  1. gx2000
    Member
    Posted 5 years ago #

    When creating a user, WP loses the username. When you go to the Verify section, I see "unverified__de0ecd8g" as a username. The email for a new user arrives okay with the correct username, but when you try to log in, it claims it is invalid.

    When you log in as an Admin, I can see the list of 2 additional users I have added, but they show the "unverified__de0ecd8g" as the username. I go to the Edit Profile for the user, change something, but it won't same b/c you need a Username. Problem is, you can't b/c it is greyed out and "Your username cannot be changed" is highlighted.

    Also the password I set up for each are not passed. so the user gets the right user and wrong password in their confirmation email.

  2. John Hoff
    Member
    Posted 5 years ago #

    Strange. Never heard of that one before, I hope your site wasn't hacked.

    You could try changing the password directly through the database:
    http://www.tamba2.org.uk/wordpress/phpmyadmin/

    You could also change the username while you're there. There's also a plugin to change your username in WordPress, if you'd like to go that route.

    Just make sure to deactivate (and maybe delete) the plugin when you're done. Not that it has a security hole, but the idea of leaving a plugin on the server which edits that information makes me nervous.

  3. gx2000
    Member
    Posted 5 years ago #

    Not necessarily a solution b/c I will need this plugin, but by deactivating the 'register-plus' plugin, it fixed my problem.

    (May need this plugin in the future so I may need to utilize the plugin you suggested, WpBlogHost.)

  4. atgheb
    Member
    Posted 4 years ago #

    I had the same problem. I fixed it by hacking the plugin.
    Then I slapped myself on the head and realized that the coding basically echoed exactly what you see in the plugin configurations.

    You cannot have "Email Verification" and "Administrator Verification" checked at the same time. If you do, it'll first check to see if you have Email Verification selected and if you do, it'll ignore the Administrator Verification which results (in the code) in certain fields being left blank i.e. the username.

    Simple solution is to make sure Email Verification is NOT selected if you want Administrator Verification. More complex solution is to hack the plugin...

    [signature moderated Please read the Forum Rules]

Topic Closed

This topic has been closed to new replies.

About this Topic