WordPress.org

Ready to get started?Download WordPress

Forums

WP-United : phpBB WordPress Integration
User registration problem (16 posts)

  1. Giurra
    Member
    Posted 1 year ago #

    Hi Jhon,
    great plugin. I'm trying to display phpbb forum in my WP page and then I found this plugin. It worked as instructed but there is one little problem. I use Full page integration option since that way forum looks great in WP page. Problem is with registering new users.
    Even before any data is entered in input fields in Register page, message:
    Please note that you will need to enter a valid e-mail address before your account is activated. You will receive an e-mail at the address you provide that contains an account activation link.
    When data is entered message above is repeated only with a number "1" in front of it. It looks like that some input fields are messed by using Full page option but can't figure it out. Any ideas?

    http://wordpress.org/extend/plugins/wp-united/

  2. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Sorry for the delay, I've been on holiday. If you've already gone and posted this in the WP-United.com forums, then please just ignore this message.

    This problem has been reported by a few other people but I haven't ever been able to reproduce it myself.

    My first suspicion is that the MODX edits to phpBB weren't applied to all your templates/styles in phpBB -- by default, AutoMod only makes changes to 'prosilver'. Can you check that the relevant changes are made to all templates & styles you are using. More information on installing MODX packages is on the phpbb.com site.

  3. Giurra
    Member
    Posted 1 year ago #

    Hi Jhong,
    Thank you for your answer.
    1) I checked registration problem with Prosilver style and the situation is the same. Same error.
    2) I checked information on phpbb.com about installing MODX packages as you instructed. But what MODX should I install? I already installed wp-united-release-phpbb by using AutoMOD as recommended. Do you recommend that I should try installation manually of the same package (wp-united-release-phpbb) or do I need to install another MODX?
    Please advise.

  4. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, for #2, I mean just ensure that the template edits in the wp-united-release-phpbb MODX have been made to the appropriate parts of your phpBB style.

    If that is OK and has been done, do you get any different results if you try with different spambot countermeasures (or by disabling spambot countermeasures)?

  5. Giurra
    Member
    Posted 1 year ago #

    Hi Jhong,
    thank you for your answer.
    I checked all the lines from install.xml for appropriate changes in styles. All the changes are there, in all the files (I use prosilver). Still no luck.
    I spambot countermeasures are completely off even before because of testing.
    I disabled all the plugins except for WP United and still error "1" during registration.
    I really like this plugin and it would be great if I could make it to work. Is there anything else that I can do?
    Thanks in advance.

  6. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Sorry you're still having problems. It's frustrating for me as well as I haven't been able to reproduce the problem.

    Other things to check:

    - what languages are you using in phpBB & WP?
    - do you have any custom profile fields?
    - what is your WordPress theme? Does it go away (temporarily) with a different theme

  7. Giurra
    Member
    Posted 1 year ago #

    Hi,
    - I'm using Serbian for WP 3.5.1 and for phpBB I used Serbian and also English. Both languages in phpBB gave same error.
    - I don't use any custom profile fields
    - my WP uses Modularity Lite theme. I tried Twenty Twelve and 2 or 3more themes just in case but no luck.

    I see that there are others with a same problem and that you were not able to reproduce the issue. If you like to, I can provide you with an access to my site if it helps.

  8. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Actually, that would be very helpful, thank you. You can contact me via the "support" form on the wp-united.com site.

    I have a massive backlog of work to get through, but should be able to take a look by the end of the weekend.

    J

  9. Giurra
    Member
    Posted 1 year ago #

    That would be great. I just sent you a info.

  10. Giurra
    Member
    Posted 1 year ago #

    Hi Jhong,
    any updates on "1" error?

  11. Giurra
    Member
    Posted 1 year ago #

    Hi Jhong,
    almost accidentally, I ran into solution for "1" error for new user registration in phpBB.
    I'm using following config:
    - Theme integration: Full page, no sidebar
    - Forum page: ON
    - Enable User integration: ON, all other options (Auto create users in...) are OFF

    When I enabled last option (User integration) error "1" was gone. I disabled it for testing purposes and got an error again. Enabled it and error was gone again...
    Hope it helps,
    Uros

  12. wojindows
    Member
    Posted 1 year ago #

    I was getting the same error with 2 separate installations. I was able to resolve both with the above workaround. Bizarre.

    Both are on 0.9.2.4
    Both had custom fields.
    They had different themes: suffusion and mystique

    If you would like any information about my installations, let me know.

  13. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Yes, I've tried to replicate this many times, and still haven't had any success yet...

    Please can you let me know the format/settings of your custom fields (and whether they are visible/required on registration). Also what settings cause the -1-? Does auto-create cause it (I don't see why it would...)?

    Thanks!

    John

  14. wojindows
    Member
    Posted 1 year ago #

    Hi John

    The 1 occurs in the error div above the username. It occurred every time, irrespective of whether the registration was successful.

    Here is a screenshot of a "successful" registration.

    The problem also still occurred whether I had the custom fields enabled or disabled. So they seem irrelevant.

    I did not have "User Integration" enabled when the problem was occurring - so "Auto Create" would not be related.

    My settings were:

    • Enable Forum Page - YES
    • Enable Login Integration - NO
    • Enable Theme Integration - YES: phpBB inside WordPress
    • Enable word censoring in WordPress - YES

    Cheers

    -- Joe

  15. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks!

    I have tested with those settings on my dev board, haven't been able to reproduce yet :(

    I'll post here when it is solved.

    J

  16. ihlonline
    Member
    Posted 11 months ago #

    Any suggestions? Same problem...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic