WordPress.org

Ready to get started?Download WordPress

Forums

User Profiles: Is there a bug in 2.02? (15 posts)

  1. elyonline
    Member
    Posted 8 years ago #

    Hi all,

    I am running WP2.02 but I just updated my user profile and now none of the HTML renders. See here: http://www.elyonline.co.uk/archives/author/kb/

    Any ideas what might be causing this?

    Thanks
    Karl

  2. elyonline
    Member
    Posted 8 years ago #

    Does no one know why this is happening? Is there a way to fix it please?

    Thank you
    Karl

  3. elyonline
    Member
    Posted 8 years ago #

    Well after some digging I came across this post:

    http://wordpress.org/support/topic/56050?replies=5

    It appears this is a bug that has yet to be fixed in 2.02. There is a patcth but for some reason it looks liked it was ignored.

    Thanks
    Karl

  4. mylagoon
    Member
    Posted 8 years ago #

    Probably wasn't added to 2.0.2 because it was a security release. Maybe look out for it in a future release, it's been tagged for 2.1; not a high priority item either in comparison to other bugs by the looks of it.

    Anyone know if this has been included in 2.0.3? You could try it yourself, I think from memory that 2.0.03 Beta is floating around somewhere, but remember that it's BETA software.

  5. elyonline
    Member
    Posted 8 years ago #

    Hmmm this wasn't fixed in 2.03.

    Karl

  6. Doodlebee
    Member
    Posted 8 years ago #

    Just curious - what do you mean the HTML doesn't render? I'm seeing everything just fine - looks like the rest of your site...

  7. elyonline
    Member
    Posted 8 years ago #

    So on my profile, you don't see any HTML? I do.

    Thanks
    Karl

  8. elyonline
    Member
    Posted 8 years ago #

    So on my profile, you don't see any HTML? I do.

    http://www.elyonline.co.uk/archives/author/kb/

    Thanks
    Karl

  9. Samuel B
    moderator
    Posted 8 years ago #

    Did you turn off the wysiwyg editor?

  10. elyonline
    Member
    Posted 8 years ago #

    samboll, yes.

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    I would think that allowing HTML in user profiles would be a security risk, potentially allowing for XSS vulnerabilities.

  12. Samuel B
    moderator
    Posted 8 years ago #

    Hmm...strange stuff. I did a test post on my blog with the html and it worked fine.
    One other possibility - do you have the box unchecked for "WordPress should correct invalidly nested XHTML automatically" ?
    admin -> options -> writing

  13. douglascoronel
    Member
    Posted 8 years ago #

    Why don't you add the thml tags on the theme/template, that way it would be more consistent from profile to profile without allowing the users to eneter html?

    Regards, D

  14. elyonline
    Member
    Posted 8 years ago #

    Hi all,

    I need to point out that this is only a problem on the user profile box in 'users' in admin and not regular posts.

    Thanks
    Karl

  15. elyonline
    Member
    Posted 8 years ago #

    I reverted back to 2.02 as I could not fix this peroblem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags