WordPress.org

Ready to get started?Download WordPress

Forums

Simply Exclude
[resolved] User permissions (4 posts)

  1. AlexAlexus
    Member
    Posted 7 months ago #

    Hello. I want to ask about user permissions.
    The ability to use SE is present only under administrator account or for other account types too (redactor, author)?
    As administrator i can use Simply Exclude plugin in posts. How to make it possible, that user under redactor's role would be able to exclude single post with Simply Exclude? In redactor's account i can't see Simply Exclude panel both in posts or account's screen settings. And i can't find option to switch it on in admin panel of a plugin.

    May be the solution is present in a settings panel and I just don't know where to put my attention?

    P.S. I use Simply Exclude in WP 3.8. It work fine, no issues.

    http://wordpress.org/plugins/simply-exclude/

  2. Paul Menard
    Member
    Plugin Author

    Posted 6 months ago #

    @AlexAlexus,

    I'm afraid that is limited to users who have the 'manage_options' role capability. By default admin users have this capability which lets then do things like activate plugins. The Simply Exclude options on the Taxonomy listing follow this logic.

    So best advice is install a Role Manager plugin. You can find plenty here on wordpress.org. Then for the needed role 'redactor' you would enable the 'manage_options' role capability.

  3. AlexAlexus
    Member
    Posted 6 months ago #

    Thanks, the solution with usage of Role Manager plugin works fine.

    May be in future i'l upgrade my "WP Taxonomy editing skills" and find a solution with no additional plugin. For now - everything is enough for the functioning.

    Thanks again.

  4. AlexAlexus
    Member
    Posted 6 months ago #

    Thanks, the solution with usage of Role Manager plugin works fine.

    May be in future i'l upgrade my "WP Taxonomy editing skills" and find a solution with no additional plugin. For now - everything is enough for the functioning.

    Thanks again.

Reply

You must log in to post.

About this Plugin

About this Topic