WordPress.org

Ready to get started?Download WordPress

Forums

User Name Changed (7 posts)

  1. willowtree
    Member
    Posted 1 year ago #

    Someone has hacked my blog and changed my user name. I managed to log in and I've changed my password, but my user name isn't very nice so I'd like to change that. Is there a way I can do this? All my posts are still there but they are not showing up on the web. I'm trying to figure out how to do a backup and go from there. Does anyone have any suggestions for me?

  2. Miroslav Glavi?
    Member
    Posted 1 year ago #

    Usernames can't be changed.

    Here is the best thing

    Log into your admin dashboard
    Click USERS
    Click Add New
    Fill the form with the username that you want.
    Role must be set to ADMINISTRATOR
    Click on Add New User

    This part is optional

    Once on the users list...click on the checkbox beside notsoniceusername. then delete it. make sure Attribute all posts and links to: <new username> is chosen. click confirm deletion

  3. willowtree
    Member
    Posted 1 year ago #

    Thanks for this info. How do I attribute all posts to the new user name? I don't see anything in the profile for the new user name to do this.

  4. willowtree
    Member
    Posted 1 year ago #

    I am also wondering why the posts are not appearing online. The posts are all still there and the permalinks haven't changed. When I click "view blog" I get a blank white screen.

  5. coupeduppro
    Member
    Posted 1 year ago #

    So, I am having this same issue. I went to log in today and had an issue. Asked for a password retrieval and when that email arrived I realized my username had been changed. I found this interesting since I thought you can't change that. So any thoughts on how this happened, Since I did not change it to the "not so nice" word it became....

  6. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    You ought to create your own thread for support with your issue.

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Sounds like perhaps your site has been hacked or someone has access to it.

Topic Closed

This topic has been closed to new replies.

About this Topic