WordPress.org

Ready to get started?Download WordPress

Forums

amr users
[resolved] User meta not picked up by amruser plus (3 posts)

  1. elurie
    Member
    Posted 10 months ago #

    hi there,
    one of the Gravity Forms custom fields is not getting picked up by the plugin. Gravity forms Check list field of 6 items are not registering in amuser plus list.

    New users appear in list even if dnp_online is checked. The Edit User page has dnp_online checked, and the mysql wp_usermeta table has dnp_online, but, in the in the amruser list, this field does not exclude these members

    I have screen shots to show this better, if you have an email i can upload jpg or png for you.
    I can also make a login to this sandbox site for you if you'd like.

    http://206.130.117.200/~wanderin/members/?sort=first_name&dir=SORT_ASC&rows_per_page=100
    alice4, alice5, alice6 all have do not publish me onine and should be excluded from the members list, while alice 7 has list everything.

    here is the admin list: admin list

    Alternately, all the other custom fields do show and work in my filters.

    many thanks,
    eve lurie

    http://wordpress.org/extend/plugins/amr-users/

  2. anmari
    Member
    Plugin Author

    Posted 10 months ago #

    Hi eve,

    Just to be sure - did you run 'find fields' in the settings ? This is usually why new fields are not showing in the config. and are there users with test data ? If no users with data in those fields, it will not find the field.

    re "New users appear in list even if dnp_online is checked." not sure what you mean by that? Lists exclude values entered - or exclude if blank. There's no if 'checked'.

    Re excluding - make sure you have the values correctly entered. Display the column first. See what values come up (or check in user meta), then enter in exclude column with no spaces between commas.

    make sure that cache is rebuilt
    and that you are using the latest version.

    If you have done/double checked all of that, and still have no success, you may email me anmari@anmari.com, but please do check yourself first. Also check you have no database / repair issues.

  3. anmari
    Member
    Plugin Author

    Posted 10 months ago #

    resolution by email and logging in investigation -
    Combination of old myssql version, inconsistent metakey's somehow causing ONLY the inconsistent meta_keys to NOT pickup the meta_keys that had underscores. Possibly due somehow to older mysql treating underscores as wildcard. Also in system with pre-existing data/settings.
    Unable to recreate in newer systems.

Reply

You must log in to post.

About this Plugin

About this Topic