WordPress.org

Ready to get started?Download WordPress

Forums

User gets two emails when new site is created (4 posts)

  1. sontru
    Member
    Posted 1 year ago #

    I've just done a brand new install of WordPress with multisite enabled.

    When I create a site, the 'admin user' of that site receives two emails.

    The first email is from a user 'wordpress' with subject title '[WP-MS_name] Your Username and password', with the username and password and the link to the toplevel site in it (only).

    The second email is from the user in the Network Settings configuration with the contents of the email from this page too.

    What is going on (is it supposed to be this way?) How do I disable the first email message being sent out?

    Any help would be appreciated. Apologies if this has been frequently asked (I did make a search for this problem before posting)...

  2. The first email is being sent because the user has registered for the network (i.e. the toplevel site)

    The second is being sent because they have a site, and are the admin.

    The reason there are two emails is that you don't always have someone making a site at the same time as the domain, so they have to be told about each set up.

  3. sontru
    Member
    Posted 1 year ago #

    Thanks for the explanation. Is there a way of disabling the first message?

    If not, is there a way of customising the first message? (Registration is disabled on my multisite. All sites are manually created.)

  4. When you manually add the user, there's a checkbox to not send them an email.

Topic Closed

This topic has been closed to new replies.

About this Topic