WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] User Community Plugin: profile and gallery directories? (22 posts)

  1. magcrossin
    Member
    Posted 5 years ago #

    Finally figuered how to get it on your forum, sorry I had trouble getting this here. Anyway please read below.

    Hello, great plugin! Just hope I can get it to work. I started out fine with the installation. Created a members page, saw the list but when I clicked on the name link there was no profile. And every time I tried to upload a photo it said there was no directory. I checked every sort of installation and usage document but I can figure how to create sub directories for profiles and the gallery? Can you please help?

    http://wordpress.org/extend/plugins/alkivia/

  2. magcrossin
    Member
    Posted 5 years ago #

  3. Txanny
    Member
    Posted 5 years ago #

    Well, the profile page is there but not shows :) Look at this:
    http://www.mysportspartner.com/index.php/our-members?user=maggie+may

    It means that for some reason, permalinks to the user profiles are not created in the proper way, as them does not include index.php in the URL.

    This is a plugin bug. A bug report has been submited to http://alkivia.org/tracker/view.php?id=84 and you can monitor it to know when it's solved.

    Will try to publish the 0.5.2 release with this fix ASAP. I think will be fixed before tomorrow night.

  4. Txanny
    Member
    Posted 5 years ago #

    Just released Community 0.5.2. This release should solve your links problem.

  5. magcrossin
    Member
    Posted 5 years ago #

    THANK YOU! That was really fast. Now is there anyway I can get the photo to show like in your screen shots? Or maybe it is a setting I have to set?

    Love this plugin:)

  6. Txanny
    Member
    Posted 5 years ago #

    Have you uploaded the pictures to the user Gallery? The only avatar shown in the page comes from Gravatar...

    The user gallery is in the User menu.

  7. magcrossin
    Member
    Posted 5 years ago #

    Yes I tried many times but I keep getting Upload error: Destination directory can't be created. Can't carry on a process. Do I have to create a directory?

  8. Txanny
    Member
    Posted 5 years ago #

    This normally is caused by rights on your WordPress uploads folder. Yo have to set there permissions that allow the server user to write files and to create and execute folders.

    After setting this rights, deactivate and reactivate the plugin to create the directories (Them are created at activation time). Look at the uploads folder, there have to be an 'alkiva' folder and inside it, a 'users' folder. (This is <uploads>/alkivia/users)

    Another way is to manually create this folders with write permissions to the server user. (to both folders, alkivia and alkivia/users).

    Just to test, you can set rights on this folders to 777. If it works, you can change them to fit your security needs, but remember that the server user always needs write access as it is who creates the files.

  9. magcrossin
    Member
    Posted 5 years ago #

    Hmmm, I tried both options but didnt work. For some reason there is a alkivia folder in wp-contents, not in uploads. But I manually added folders wp-contents/alkivia/users with write permission for both, but still getting the same error

  10. magcrossin
    Member
    Posted 5 years ago #

    I have also deactivated and reactivated the plugin after setting write permission to uploads folder, but that didnt work either.

  11. magcrossin
    Member
    Posted 5 years ago #

    I just realized in my control panel file manager the alkivia outside uploads, the one the plugin created has uneditable permissions with user: apache

    alkivia 4.00 KB rwx r-x r-x April 7, 2009 apache apache
    plugins 4.00 KB rwx rwx rwx May 3, 2009 redshoegirl11 psacln
    themes 4.00 KB rwx rwx rwx April 29, 2009 redshoegirl11 psacln
    upgrade 4.00 KB rwx rwx rwx May 3, 2009 redshoegirl11 psacln
    uploads 4.00 KB rwx rwx rwx May 3, 2009 apache apache
    index.php 4.00 KB rw- r-- r-- April 29, 2009 redshoegirl11 psacln

    7 files and directories in mysportspartner.com / httpdocs / wp-content total Number of entries per page: 10 25 100 ALL

  12. Txanny
    Member
    Posted 5 years ago #

    If the folder was created outside the uploads folder, normally is a WordPress misconfiguration. Look at this: http://wordpress.org/support/topic/267058

  13. magcrossin
    Member
    Posted 5 years ago #

    OK great, I fix the problem with the folders. Now I can upload the admin1.jpg and it generates 2 more files admin1_avatar.jpg and admin1_thumb.jpg. But unfortunately the thumb is the only file that shows. Any idea why?

  14. magcrossin
    Member
    Posted 5 years ago #

    Actually its just the Main Photo thumb that shows, nothing else. Here is the link: http://www.mysportspartner.com/index.php/our-members/user/admin
    But I do see them in the control panel and the admin panel with a red X.

  15. Txanny
    Member
    Posted 5 years ago #

    Shown image is the profile size. Checking it's name you can see it, as thumbnail images ends with _thum. So, you have to check the image sizes you've set on the gallery settings or, if using WordPress defaults, on the WordPress media settings.

    Also, check your server and WordPress settings, as sometimes the uploads folder shows as "uploads" and others shows as "upLoads" (Note the upercase L). In the last case it does not works because that folder with upercase L does not exists on disk.

  16. magcrossin
    Member
    Posted 5 years ago #

    Yes thats exactly what happened, there are two folders one with the uppercase. I decided to not deal with it too much as it was uploading, but I guess I was wrong. So I cant have the upLoad folder? Everytime I deleted it, it kept coming back. Any idea how I can get rid of it?

    Sorry to be such a bother with this, I really appreciate you taking the time to help me.

  17. magcrossin
    Member
    Posted 5 years ago #

    OK I figured it out! In the Miscellaneous settings, I had the L capital because thats what it had in the example. Anyway changed it and it works! But somewhere along the way I set the Large image at 20px, but cant remember where that was. Have to hunt for that now.

  18. JaneFancher
    Member
    Posted 5 years ago #

    Hiya. My site is: http://www.janefancher.com/TheCaptainAndLime/ but I'm not really having problems with the plugin per se. In fact, I think it's going to be great.

    I would like my default avatars to be the wavatars. How, please, do I do that?

    Thanks for your help.

  19. Txanny
    Member
    Posted 5 years ago #

    You're right, by now you cannot set other than local anonymous when using the gallery component. I will manage it for a next version, to allow defaults from Gravatar.

    Please, start a new topic when not following the current. It is difficult to follow a mix of unrelated questions.

  20. Txanny
    Member
    Posted 5 years ago #

    magcrossin,

    You can change the images size in the plugin gallery settings.

  21. magcrossin
    Member
    Posted 5 years ago #

    Thank you, it works perfectly!!!!!

  22. Txanny
    Member
    Posted 5 years ago #

    I'm happy you have solved all this and like the plugin :)
    I know, I have to spend more time on manuals ;)

Topic Closed

This topic has been closed to new replies.

About this Topic