WordPress.org

Ready to get started?Download WordPress

Forums

user "admin" doesn't appear in the "post author" tab (5 posts)

  1. pmguerre
    Member
    Posted 7 years ago #

    Hi there.

    I'm having a problem with wordpress, and from the search I've made, I can't find any reference to this particular problem.

    In the menu Users -> Authors & Users, if I change the "Display name publicly as:" option from the user "admin", from now on this users doesn't appear in the "Post Author" option in the "Write Posts/Pages"... Is this on purpose or is this a bug?

    I've tried several times, instaled fom scratch, remove all plugins, remove all themes, you name it, I've done it...

    Then I've gone and changed "Display name publicly as:" back to "admin" and it worked again...

    Am I the first to encounter this problem?

    Thanks

    UPDATE: The second time I change "Display name publicly as:" to something else (I'm using First_Name Last_Name) it works...

  2. asquare
    Member
    Posted 7 years ago #

    Having the same problem as pmguerre, can't post as admin because admin does not appear in the Post Author box on Post pages. Changing the admin display name doesn't help (I've tried all combinations). I have three users on my weblog, one admin and two editors, this issue only happens after the second editor is added (when the Post Author box appears) which doesn't make sense, surely it should be after the second user (the first editor) is added? Any help much appreciated.

    a+
    gar

  3. asquare
    Member
    Posted 7 years ago #

    This seems to work if anyone else has the same issue:

    If you are an admin, try to set your account to anything other than admin from the Your Account page. WordPress will not do this, don't worry. Next set your account back to being an admin (even though it never changed). You should now see your admin account in the Post Author box on the Post pages.

  4. bomb2001
    Member
    Posted 6 years ago #

    That worked for me. Thanks asquare.

  5. JohnP
    Member
    Posted 6 years ago #

    I have reproduced this issue on a fresh install of WP2.1.3 with the default theme and no Plugins.

    Immediately I add a second user with the rank of contributor or above, "Admin" disappears from the author list and pages and posts are attributed to Secondusername.

    Setting a nickname other than Admin on the "Your Profile" page has fixed the problem - thanks for the info asquare.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.