WordPress.org

Ready to get started?Download WordPress

Forums

Genesis Simple Hooks
[resolved] use Plug-in with older Genesis Version (10 posts)

  1. mkae
    Member
    Posted 7 months ago #

    Hi,

    I updated the Simple Hooks Plugin to the newest version. After that I deactivated it. Now, when I try to reactivate the Plug-in, the following message appears:

    Sorry, you cannot run Simple Hooks without WordPress 3.6 and Genesis 2.0.0, or greater.

    I don't want to loose all the code in the hooks.

    thx for your support.

    http://wordpress.org/plugins/genesis-simple-hooks/

  2. mkae
    Member
    Posted 7 months ago #

    Genesis Version I use is 1.9.2

  3. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 7 months ago #

    uninstall the plugin and manually install an older version (see the Developer tab on the plugin page).

  4. anefarious1
    Member
    Posted 7 months ago #

    That's a great idea using the developer tab to get an older version. Unfortunately I got the same result as many others on here. A fatal error occurs and I had to install it. Hope someone can eventually figures out why this thing doesn't work.

  5. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 7 months ago #

    That's a great idea using the developer tab to get an older version.

    You can do that with any plugin in the repository.

    Unfortunately I got the same result as many others on here.

    I read all of the threads for Genesis Simple hooks. There have not been any threads where someone downgraded Genesis & reported an issue with installing an older version.

    Perhaps you could help me help you by telling me which version you tried to install after you removed the version for Genesis 2.0.X.

  6. anefarious1
    Member
    Posted 7 months ago #

    You can do that with any plugin in the repository.

    Yes I realize that now, thanks.

    I read all of the threads for Genesis Simple hooks. There have not been any threads where someone downgraded Genesis & reported an issue with installing an older version.

    Perhaps you could help me help you by telling me which version you tried to install after you removed the version for Genesis 2.0.X.

    I've tried several versions such as 1.8.1, 1.8, 1.7.1 and all give the same result:

    Fatal error: Class 'Genesis_Admin_Boxes' not found in

    /home/www/mysite.com/wp-content/plugins/genesis-simple-hooks/admin.php on line 13 on a white background, it breaks the site and then I cannot access the plugins area at all. I have to change the plugin's folder name and uninstall it.

    I've seen several threads regarding this error but no solution so that's what I was referring to. Thanks for your help.

    PS: I'm running Genesis 1.7

  7. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 7 months ago #

    I've tried several versions such as 1.8.1, 1.8, 1.7.1 and all give the same result:

    The 1.7.1 version does not rely on (or reference) Genesis_Admin_Boxes. It's the appropriate version for Genesis 1.7.X.

  8. anefarious1
    Member
    Posted 7 months ago #

    I will try 1.7.1 again and get back to you. Thanks

  9. mkae
    Member
    Posted 7 months ago #

    Hey Ron,

    thx for your help. I was able to fix it with your hint.

  10. anefarious1
    Member
    Posted 7 months ago #

    I must have tried everything but 1.7.1 because it works! Thanks. Any idea how to turn off the update notification for this old version?

Reply

You must log in to post.

About this Plugin

About this Topic