WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] Use embedding on some pages and links on others (8 posts)

  1. JTobey
    Member
    Posted 1 year ago #

    So I have a few pages where I want to embed a PDF, and others where I want to the text to be linked to the doc. Other than writing the HTML myself (my users need something simple), is there a way to turn off the plugin on certain pages?

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Can you clarify what you mean about "I want to the text to be linked to the doc"?

    For pages where you don't want the viewer, you don't need to use the shortcode at all, but just insert the link using standard WP means. I presume this isn't what you mean, though, so feel free to explain further.

    Thanks,

    Kevin

  3. JTobey
    Member
    Posted 1 year ago #

    No worries, I figured it out, I have to code the href to do what I want.

    Thanks.

  4. amulligan
    Member
    Posted 1 year ago #

    Hi Kevin,
    I think I have the same question as JTobey. The Upload/Insert button in the Edit Page section of WordPress appears to automatically default to Google Doc Embedder when adding media to the page. If I'm editing the page that's not a problem as I can just code the href on the HTML side like JTobey seems to have done. However, that's a bit of a fiddle for my users who are trying to edit their own pages.

    Is there any way to make the Upload/Insert button default to the standard WordPress text link and only have the Google Doc Embedder work when it's button is used from the editing bar?

    Many thanks, great plugin by the way!

    Alex.

  5. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Certainly, this behavior in GDE can be turned off.

    In GDE 2.4.x:

    GDE Settings > Advanced Options/Editor Behavior > uncheck "insert shortcode from Media Library"

    In GDE 2.5:

    If you're using WP 3.4.x, you can check/uncheck a box in the media library itself to use the shortcode or not at the time of insertion. This does not work with the uploader changes in WP 3.5 beta yet, but the above setting still exists also:

    GDE Settings > Advanced tab > uncheck "Insert shortcode from Media Library by default"

    Hope this helps.

    Kevin

  6. amulligan
    Member
    Posted 1 year ago #

    Immense!
    Thanks for the help!

    Alex.

  7. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    My pleasure. Thanks for the kind remarks about the plugin.

    In hindsight, I'm sorry JTobey for misunderstanding your question. Hopefully this answer is more helpful. :)

    Kevin

  8. JTobey
    Member
    Posted 1 year ago #

    Ahhhh...thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic