WordPress.org

Ready to get started?Download WordPress

Forums

URLs with &page=xx in them not working (5 posts)

  1. theKiwi
    Member
    Posted 2 years ago #

    I have a couple of WordPress sites that I use for genealogy. They're using a plug-in tng.php that puts the content of a TNG - The Next Generation of Genealogy Site Building - http://tngsitebuilding.com - into a WordPress page.

    This TNG software uses a lot of parameters in its URLs to display content on its many different pages. For example

    http://lisaandroger.com/genealogy/browsemedia.php?mediasearch=&tnggallery=&mediatypeID=photos&offset=50&tree=&page=2

    Up to and including WordPress 3.3.2, these worked OK with the tng.php plugin and WordPress, but as of 3.4 the URL above is being rewritten by WordPress to become

    http://lisaandroger.com/genealogy/2/?mediasearch&tnggallery&mediatypeID=photos&offset=50&tree

    which fails - the "browsemedia.php" has been removed and "&page=2" has been rewritten so that

    /2/

    comes after the URL to the WordPress page. Of course it now fails to load the expected page

    Any ideas where in WordPress this behaviour can be altered?

    The tng.php plugin is not really under active development by anyone who knows much about WordPress - the TNG developer and I have made a few tweaks to it over the past months, but are both pretty much oblivious to the inner workings of WordPress. The original developer of the tng.php plugin is now not involved at all.

    Thanks!!

    Roger

  2. nielsfogt
    Member
    Posted 1 year ago #

    Hey @theKiwi..did you ever get this figured out? I'm having a similar issue :(

  3. theKiwi
    Member
    Posted 1 year ago #

    I didn't figure it out from the WordPress side - I altered the script I was using for genealogy software to use

    &tngpage=

    That seemed much easier.

    Roger

  4. nielsfogt
    Member
    Posted 1 year ago #

    cool...well for what it is worth...i had a somewhat similar issue and just ran flush_rewrite_rules(); which cleared it all up for me

  5. HeatherFeuer
    Member
    Posted 1 year ago #

    nielsfogt, can you explain how you ran that?

Topic Closed

This topic has been closed to new replies.

About this Topic