WordPress.org

Ready to get started?Download WordPress

Forums

URL's & Links on multiple WP installs in separate sub-folders on single host (5 posts)

  1. Mojito0481
    Member
    Posted 1 year ago #

    Following the advice of GoDaddy Tech Support, I consolidated all 7 of my websites to a single hosting account to save money (which did save me a good bit). I am using WordPress for all of my sites and installed separate instances of WP into sub-folders for each respective website.
    site1.com/site1
    site1.com/site2
    site1.com/site3 ... etc.

    By default, URL site2.com takes me to the correct home page, but the URL's for all other pages/posts/etc. show the full file path like "site1.com/site2/page2/".

    When I change the setting in General Settings "Site Address (URL)" to http://site2.com the main page URL is correct (site2.com) and still works but then all of the other links are completely broken and give errors (although the URL now displays correctly, site2.com/page2 ). Also, if I go back to the home page the URL now shows the full filepath again rather than site2.com.

    GoDaddy Tech Support just said, "Yeah, that should have worked. It shouldn't do that." Which is obviously no help.

    I have tried updating the .htaccess files (as some people have suggested), but I wasn't able to get that to work either.

    I have been researching this for over a month now and haven't found a solution. It seems like every time I find a forum with this issue the topic has been closed without resolution.

    Is it really unsolvable? I am hoping the right people just haven't addressed the issue yet.

    Can anyone help?

  2. Mojito0481
    Member
    Posted 1 year ago #

    Here are some similar topics I found on here:

    http://wordpress.org/support/topic/multiple-blogs-on-godaddy-1?replies=7 <--- this one is old, but was not resolved ... by the way, I have Linux hosting not Windows hosting as mentioned in this post

    http://wordpress.org/support/topic/installing-wp-for-several-blogs-on-a-single-host?replies=6 <-- tried this .htaccess trick, but didn't work for me.

  3. Go Daddy
    Go Daddy Support
    Posted 1 year ago #

    It sounds like you have either a Deluxe or higher hosting plan.

    In that case, you can add multiple domains to the account, which you may have already done. http://go.me/kl

    Each domain designates a folder as its own root. When you install WordPress into each of those domains' folders, you'll still just specify the domain itself and leave the directory field empty. Once you've installed it, you should be able to restore the database for the installation and it should appear as a standalone site.

    If I'm understanding your question correctly, you may already have this set up properly and the links are broken when you change your site address. Resetting the permalinks (disable/re-enable) could solve the issue with the broken links.

    If you have a ticket with support that I can review, please feel free to post it here.

    ^Cj

  4. Mojito0481
    Member
    Posted 1 year ago #

    Thank you for the response.

    I do not see the enable/disable feature for the permalinks. I only see where to change their format.

    When I discussed this issue with tech support, the reason I had called was primarily to get guidance on another issue. So I did not have an open support ticket for this issue. I just submitted one so that you can access the details of my situation.

    Ticket #: 19502700

    Please let me know if you have additional questions. I would greatly appreciate any help you can provide.

  5. Go Daddy
    Go Daddy Support
    Posted 1 year ago #

    It looks like the instructions for resetting the Permalinks was sent to you in response to the ticket. Can you let me know if you're still having trouble or if that has helped to resolve the issue?

    ^Cj

Topic Closed

This topic has been closed to new replies.

About this Topic