WordPress.org

Ready to get started?Download WordPress

Forums

URL special chars not escaping properly (3 posts)

  1. Asmodiel
    Member
    Posted 2 years ago #

    Hey guys,

    I know, I'm not the owner of this page and it's probably a bit stupid to post it, but I think that's a bug in wordpress we should be able to reproduce (I'll try and to that tomorrow).

    To the point:
    A friend of mine posted this link http://www.addictinginfo.org/2012/08/20/why-anti-abortion-≠-pro-life/ and it came out scrabled like this (which is what you get when you copy the url field): http://www.addictinginfo.org/2012/08/20/why-anti-abortion-%E2%89%A0-pro-life/ or http://www.addictinginfo.org/2012/08/20/why-anti-abortion-%C3%A2%20-pro-life/ (which yields a 404)
    I know this is usual url encoding but I was pretty sure wordpress was escaping characters like that to minuses ( - ). What went wrong there?

    Have a nice night,

    Asmodiel

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Manually retype the permalink (slug) for that post and do not use special Unicode characters in manually setting slugs. not equals is not a special character such as !@#$%^&*()_|}{{}":';<>,.

  3. Asmodiel
    Member
    Posted 2 years ago #

    I know how to fix this (and I'm not the owner of the blog), what I meant was that I think that wordpress might consider reminding the user in some subtle way of how unicode characters in URLs might give you a hard time.
    I'm not a wordpress core developer and I don't want to be so I thought the forums would be a good place to adress a discussion about this.

Topic Closed

This topic has been closed to new replies.

About this Topic