WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] URL site address problem (8 posts)

  1. Croglish
    Member
    Posted 3 years ago #

    Hi.

    I have wordpress installed in "www.example.com/wordpress/" directory.
    I've tried by the book to set my index.php and web.config file into core folder of my web site and there is no result.

    I've changed index.php file as it is explained in this link:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    But still, I don't get anything when I open my "www.example.com" link..
    It just works when I add "/wordpress"

    Thank you.

  2. You only put index.php into the root, not wp-config.php

    Make sure you've also updated the wp-blog-header.php path in your index.php file, put your .htaccess in the root as well, changed your and Site address (URL) in Site Settings, and reset your permalinks, following the instructions in the Codex.

  3. Croglish
    Member
    Posted 3 years ago #

    Zoonini thank you on reply. Please read again what I've wrote. I wrote web.config file, not wp-config.php.
    web.config is a file that exist if you use windows based server. I don't have .htaccess file because it exist if you use linux based server for wordpress.

    Also I've said that I did exactly how it is described in codex (link in my first post) and it didn't work.
    I think that it is little bit different with windows based server.

    I'm not sure do I have to delete web.config file and/or index.php file in my http://www.example.com/wordpress/ folder when I copy them into core folder.

    How do you mean reset your permalinks in dashboard?

  4. Croglish
    Member
    Posted 3 years ago #

    Update.

    Problem solved. I've tried again (3rd time) whole procedure from codex and now it works but still It have small problem.

    when I open my URL with: http://www.example.com, after loading in address bar it switches it to example.com.

    If I edit permalinks, and set there www, will it work?

    M.

  5. Ah - sorry I misunderstood about the config file - I've never heard of it before and assumed you made a typo. In future it would be valuable to mention that you're hosting on Windows as that's a less common scenario that often has its own particularities.

    I'm very glad you got it sorted, though!

    when I open my URL with: http://www.example.com, after loading in address bar it switches it to example.com.

    In General Settings, do you have www included in the Site URL and Blog URL?

    If not, add it now.

    If yes, then it's probably a site or server setting that's removing the www and you'll need to either tweak it yourself on the account or server level or ask your host for assistance.

    If I edit permalinks, and set there www, will it work?

    I don't think that's the right spot for it - permalinks is only for your link structure, not the base URL.

    Good luck!

  6. Croglish
    Member
    Posted 3 years ago #

    In General Settings, do you have www included in the Site URL and Blog URL?

    Bingo!

    Tested on Chrome, Firefox and Safari, it works fine now.

    Thank you again.

    p.s. If you read carefully the codex page for setting your core folder for wp, you'll see that they made typo... they wrote veb.config instead web.config :P

    I'm not sure to who I can address that problem :)

  7. Glad your site is all fixed!

    p.s. If you read carefully the codex page for setting your core folder for wp, you'll see that they made typo... they wrote veb.config instead web.config :P

    I'm not sure to who I can address that problem :)

    I could make that fix but I can't seem to find it. Can you give me the URL and the approximate spot on the page? I did a search on the page you referenced in your first post, above, but couldn't find it. Thanks!

  8. Croglish
    Member
    Posted 3 years ago #

    URL is:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    But now when I quoted the text I see where is the problem... Problem is actually in my browser where letter W looks like V... everything is alright on the end :) It is probably because web.config is quoted on a page as code.

Topic Closed

This topic has been closed to new replies.

About this Topic