WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] url showing blank page (14 posts)

  1. kimnewton
    Member
    Posted 5 years ago #

    I have installed wordpress in my root directory but when I go to my domain name url it is a blank page. Not sure what setting I need to change to make the index.php work?

  2. sarmadhassan
    Member
    Posted 5 years ago #

    check if your dns is pointing correctly
    check the page source if its showing anything..
    check if you have .htaccess in place..
    check all file permissions..

  3. kimnewton
    Member
    Posted 5 years ago #

    sarmadhassan, thank you
    Basically everything works if I create a sub folder and put everything in that, but with the mydomain.com/wordpress but when I put everything in the root directory I would be directed to my host services index.html file, so they had me move the index.php up to the beginning of the list and that is when I go to mydomain.com url I get a blank page.
    the dns is pointing correctly
    the page source seems correct
    Where do I find the .htaccess file I have tried to find this earlier
    permissions are all correct
    Thanks so much for your help
    Kim

  4. iridiax
    Member
    Posted 5 years ago #

    If you have an index.html in your root directory, get rid of it.

  5. kimnewton
    Member
    Posted 5 years ago #

    Thanks, I got rid of it, but it is still the same
    Kim

  6. sarmadhassan
    Member
    Posted 5 years ago #

    seems like you installed wordpress in sub directory before and now moving to the root.. or there are files in the root from your previous site..

    1) remove all "YOUR" files (which you uploaded in the root previously) better backup before delete..

    2) download fresh wordpress... unzip on your computer.. upload all the files straight to the server without involving the wordpress folder.. the wordpress files include .htaccess

    3) enter your db details and get a fresh install.. it SHOULD work now !

    (writing noobs language coz i think you are new to wordpress) :)

  7. kimnewton
    Member
    Posted 5 years ago #

    Thanks I'll give that a shot.
    By the way, there is an index.wml file in my root directory, should I remove that too?
    Thanks again

  8. kimnewton
    Member
    Posted 5 years ago #

    You, know I downloaded a new version and there still isn't a .htaccess file anywhere.
    Yes very nooby to wordpress (:
    thanks your patience and above all help

  9. sarmadhassan
    Member
    Posted 5 years ago #

    ya sorry.. i confused wordpress with joomla.. go on and do steps (2).. (3).. hope things would get good for you !

  10. kimnewton
    Member
    Posted 5 years ago #

    Thanks for all your help. I did all this. Still goes to a blank page.
    Best

  11. vietknight
    Member
    Posted 5 years ago #

    Read this first

    http://codex.wordpress.org/Installing_WordPress

    Follow the directions carefully.

    Make sure the directory you wish to install WordPress is clean (aka no files inside it). Confirm all your files have been uploaded properly with the correct upload settigs for the different types of files (ASCII vs. Binary uploading)

    Also read this:

    http://codex.wordpress.org/Installing_WordPress#Common_Installation_Problems

    Lastly, if all goes wrong, copy&paste your error log here.

  12. kimnewton
    Member
    Posted 5 years ago #

    Thanks again, turns out that the host dotster.com does not support WordPress 2.6.2 and it is not possible to install it on their hosting service. I am moving to a new host, but wondered of the ones listed on the WordPress.org website as recommended, which one is the best overall for reliability and customer service.
    Thanks again

  13. sarmadhassan
    Member
    Posted 5 years ago #

    Thanks again, turns out that the host dotster.com does not support WordPress 2.6.2 and it is not possible to install it on their hosting service. I am moving to a new host, but wondered of the ones listed on the WordPress.org website as recommended, which one is the best overall for reliability and customer service.
    Thanks again

    If that is the case.. its really bad.. by the way i dont see any reason for hosts not supporting latest 2.6.2

  14. Gr1f
    Member
    Posted 5 years ago #

    I'll also like to add to this thread.

    I had the same issue after moving 2.7 from local install to web server.

    Checked all urls in the database and all were fine, as was wp-config.

    I then tried renaming the plugins folder and viola! Blog back up. I then went about creating a new plugins dir and adding plugins one by one. The culprit, for me, was 'breadcrumb-navxt'. If that was added i got blank page once again. No idea why though....

    Hope this helps someone.

Topic Closed

This topic has been closed to new replies.

About this Topic