WordPress.org

Ready to get started?Download WordPress

Forums

URL Rewrite 404 error - WP Network on IIS 7.5 (1 post)

  1. wasseng
    Member
    Posted 6 months ago #

    I'm stuck.

    I'm having 404 trouble when setting up a simple(?)WP Network - after newly installed WP 3.8.1 on a IIS 7.5 server. Guessing that my problem is in the URL re-write rules that WP supplied me with. I don't know how to set them straight.

    My main site still works fine after I set up the network, but sub sites loads content but cant find CSS-files (404). Also get 404 trying to reach wp-admin for sub-sites. AS mentioned, I used the web.config that was supplied by the network-installation, so I haven't meddled with it.

    I'm trying to use directories, not sub-domains.
    * inside.companyname.com (main-site)
    * inside.companyname.com/sales (sales wanted a seperate site)
    * inside.companyname.com/testarea (seperate testsite for theme-modding)

    http://inside.companyname.com/wp-admin (works!)
    http://inside.companyname.com/wp-admin/network (works!)
    http://inside.companyname.com/sales/wp-admin (gives 404!)

    This is the web-config that I used:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="{R:1}" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>

    wp-config

    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'inside.companyname.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    Appreciate the help!

Reply

You must log in to post.

About this Topic