WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] URL problem with Flickr Plugin (2 posts)

  1. streetsweeper
    Member
    Posted 6 years ago #

    Hi

    I'm using WP 2.2 and 'Flickr Photo Album' .92

    It's a terrific plugin and just what I was after - but I can' seem to make it work properly.

    My albums page works great, but I cannot select any of the actual photos or individual albums - the link points to a 404 not found page.

    My albums page is:

    http://www.streetsweeper.net.au/wordpress/?page_id=134/

    http://www.streetsweeper.net.au/wordpress/album/72157594486470099/photo/517763011/swpr-hi-res-publicity-watermelon-highway.html

    I've installed the plugin, set all the permmissions and permalink parameters, reinstalled over and over again.

    Another user has pointed out to me that if you add "?page_id=134" into the url the link works fine - see below...

    http://www.streetsweeper.net.au/wordpress/?page_id=134/album/72157594486470099/photo/517763011/swpr-hi-res-publicity-watermelon-highway.html

    It seems that however the plugin/php coding works, (like magic to a non programmer like me), it doesn't put the "?page_id=134" into the links from the primary Album page. I can't work out what I have missed out on. Can I change one of the php files?

    I thought that maybe the "path" needed to be "achives/134" but that didn't work. All of the photo links work if I add the "?page_id=134" as you did. Other than that I've tried my settings in all different ways.

    I think I understand that I have to create a page named "album" in WP.

    I've changed the Permalink structure to numeric.

    I don't understand how to create a page for 'Photo Album' that WP will publish with the url 'album'. I can only publish pages with the three number page id - i.e. "?page_id=135" - and therefore I don't think the flickr datbase has a url that will link to my album.....

    Any help appreciated! Sorry for such a long post!

  2. streetsweeper
    Member
    Posted 6 years ago #

    I have resolved this issue.

    It was the mod_rewrite access on my ISP's side. They have contacted me today and switched the mod_rewrite on.

    thankyou all

Topic Closed

This topic has been closed to new replies.

About this Topic