WordPress.org

Ready to get started?Download WordPress

Forums

url missing / when new blog created (10 posts)

  1. sniperfora
    Member
    Posted 3 years ago #

    hello
    when ever any one sign up and create new blog or I create new blog from wp-admin
    the url missing /
    for example
    if I create new blog
    http://www.mysite.com/newblog
    the url become like this
    http://www.mysite.comnewblog

    and always I go to option of newblog to correct the url

    how can I fix that ?

  2. The / is missing from the base value in the wp-config. (I think - check there first.)

  3. sniperfora
    Member
    Posted 3 years ago #

    my config is this

    <?php
    /**
     * The base configurations of the WordPress.
     *
     **************************************************************************
     * Do not try to create this file manually. Read the README.txt and run the
     * web installer.
     **************************************************************************
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
     * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation.
     *
     * @package WordPress
     */
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'no');
    $base = '';
    define('DOMAIN_CURRENT_SITE', 'www.xxxxx.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    // double check $base
    if( $base == '/' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    //define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** WordPress absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    what should I change ?
    thank you

  4. dgilmour
    Member
    Posted 3 years ago #

    $base = '';

    becomes

    $base = '/';

  5. sniperfora
    Member
    Posted 3 years ago #

    when I did that I get this error
    Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!

  6. Why did you install wpmu and not wordpress 3.0?

  7. bondi
    Member
    Posted 3 years ago #

    when i went to 3.0 from mu it broke all media links every ones missing there images for some reason it goes to /file/ and not /blogdir and now i am trying to revers back to mu. lots of stress all week. and every one is pointing the finger at every one else in this forum very confusing that doesn't really help.
    So mu-2.9 until the light comes through
    config line Base! wot will this affect

    "/blogs/"
    or
    "/"
    will i end up with the upgrade 3 prob loss of media???

  8. images for some reason it goes to /file/ and not /blogdir

    It's SUPPOSED to go to files. Did you update the .htaccess file? Directions are here: http://wpmututorials.com/how-to/upgrading-from-wpmu-to-wp-3-0/

    So mu-2.9 until the light comes through
    config line Base! wot will this affect

    I'm sorry, I don't understand what you're asking.

  9. sniperfora
    Member
    Posted 3 years ago #

    Why did you install wpmu and not wordpress 3.0?

    I don't
    I was using mu and upgrade it to wordpress 3
    then I face this problem

  10. when i went to 3.0 from mu it broke all media links every ones missing there images for some reason it goes to /file/ and not /blogdir and now i am trying to revers back to mu

    On upgrade there's a yellow alert message in the backend about changing the rewrite rules for the uploaded media files.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags