WordPress.org

Ready to get started?Download WordPress

Forums

URL Links Generating Incorrectly (11 posts)

  1. rdeese
    Member
    Posted 1 year ago #

    The links for URLs on some site pages and many admin pages are not being generated correctly. For some reason the site address is being repeated twice.

    Here is my project's web site:
    http://manoa.hawaii.edu/pbrrtc/hooikaika/

    You can see an example of the problem if you hit "older posts" on the bottom of the front page. This is what it generates:
    http://manoa.hawaii.edu/pbrrtc/hooikaika/manoa.hawaii.edu/pbrrtc/hooikaika/?paged=2

    This is what it should look like:
    http://manoa.hawaii.edu/pbrrtc/hooikaika/?paged=2

    I updated to the newest version of wordpress and switched to one of the default templates to see if it would fix the problem but no luck. I'm not currently using permalinks.

    I'm not sure what to try and I'm not entirely sure what to search for to find information about this problem. Most searches "for URL generating incorrectly" find information about how to fix problems with permalinks.

    Thank you for any help you can give.

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Try turning off the plugins and see if it makes any difference.

  3. rdeese
    Member
    Posted 1 year ago #

    The only plugins installed right now are Akismet and Hello Dolly, so I tried turning those off. It doesn't seem to fix the problem on the main page or on the administrator pages. I can still use a lot of the administrator controls, but anything that requires loading a new page isn't working correctly, such as going to page 2 in the media library

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  5. rdeese
    Member
    Posted 1 year ago #

    Thanks Esmi. The site is already on the default setting, since I never configured Permalinks. I tried to at one point, but the type of hosting I have made it difficult.

    Are there any other common fixes I should try?

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    What urls do you have entered in Settings -> General? Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  7. rdeese
    Member
    Posted 1 year ago #

    In general settings:

    WordPress Address is http://manoa.hawaii.edu/pbrrtc/hooikaika
    Site Address is http://manoa.hawaii.edu/pbrrtc/hooikaika

    Plugins are currently deactivated. I manually deactivated the plugins by FTP, but it doesn't seem to have an effect.

    The problem still seems to occur on the Twenty Eleven theme, so it wouldn't be theme problem.

    I had just completed a clean install of WordPress when the problem emerged. It's possible that modifications made to the old install may have actually been keeping the problem under control.

    So far no luck, but I really appreciate the advice.

  8. rdeese
    Member
    Posted 1 year ago #

    Found a new behavior. On the site pages generated by the 2010 and 2011 themes, I get a "Page Not Found" error with the bad links that are generated. On the admin pages, I am getting a 403 "Forbidden" error or being redirected to the login screen. This happens when trying to go from page 1 to page 2 of the media library, and similar pages.

    This is the link that it is generating:
    http://web41.its.hawaii.edu/manoa.hawaii.edu/pbrrtc/hooikaika/wp-admin/edit-comments.php?paged=2

    This is what I think the link is supposed to look like:
    http://manoa.hawaii.edu/pbrrtc/hooikaika/wp-admin/edit-comments.php?paged=2

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    The site is behaving as if it was originally installed on http://web41.its.hawaii.edu/manoa.hawaii.edu/pbrrtc/hooikaika/ Do you know if that was ever the case? It might also be worth speaking to the server admin to see how the manoa.hawaii.edu sub-domain has actually been set up. It could be a problem at the server/DNS level.

  10. rdeese
    Member
    Posted 1 year ago #

    web41.its.hawaii.edu is actually the name of the current server. I checked the FTP bookmarks and that's what they are set up to log into. I will try to contact someone in the university's ITS department and see if they can shed some light on the situation.

  11. rdeese
    Member
    Posted 1 year ago #

    Someone from the university ITS department was able to fix the problem. When I updated the WordPress config file, I overwrote some code that was making it work with their DNS setup. They inserted the code back in.

    // Server Path Rewrite Rules
    if ( isset( $_SERVER['HTTP_X_FORWARDED_HOST'] ) )
    {
       $_SERVER['HTTP_HOST'] = $_SERVER['HTTP_X_FORWARDED_HOST'];
       $_SERVER['REQUEST_URI'] = preg_replace("/^\/manoa.hawaii.edu\//", "/", $_SERVER['REQUEST_URI']);
    }

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.