WordPress.org

Ready to get started?Download WordPress

Forums

Amazon S3 and Cloudfront
[resolved] URL Isn't Rewriting (5 posts)

  1. jdcauley
    Member
    Posted 2 months ago #

    So our url's aren't rewriting to reflect the either the S3 url or our cloudfront url.
    Any idea what is going on?

    Jordan

    https://wordpress.org/plugins/amazon-s3-and-cloudfront/

  2. Brad Touesnard
    Member
    Plugin Author

    Posted 2 months ago #

    Do you have it turned on in the options page?

  3. jdcauley
    Member
    Posted 2 months ago #

    I will accept the egg on my face.

    I suppose it helps if you read the options all the way.

    Sorry

    Jordan

  4. timmah2
    Member
    Posted 1 month ago #

    Hi gents,

    I must have egg on my face as well. Is the 'options page' AWS > Amazon S3 and CloudFront?

    I can't get it to upload to S3 or rewrite URLs. I'm on WP 3.9.1

    (IAM has permission, tried in wp-config and db).

    Tim

  5. timmah2
    Member
    Posted 1 month ago #

    More on this, found a bug in the code.

    Line 163 of amazon-s3-and-cloudfront.php an exception getting caught:

    AWS Error Code: PermanentRedirect, Status Code: 301, AWS Request ID: ##, AWS Error Type: client, AWS Error Message: The bucket you are attempting to access must be addressed using the specified endpoint.

    To fix this I needed to put my 'region' into the instantiation of get_client() in /amazon-web-services/classes/amazon-web-services.php

Reply

You must log in to post.

About this Plugin

About this Topic