WordPress.org

Ready to get started?Download WordPress

Forums

URL Incorrect (8 posts)

  1. KPIZME
    Member
    Posted 9 years ago #

    I'm almost there. So far, installation has been fairly painless. However, now something else is wrong, affecting the blogs main functionality. All my internal, links are wrong. For example:

    When logged into WP-Admin, the "View Site" url is missing the index.php at the end. It is just; http://<myurl>/wordpress/" instead of the full path "http://<myurl>/wordpress/index.php"

    The same holds true for all the internal links, so nothing works right, unless I manually type the "/index.php" in.

    I am on a Windows Server coloctated off site, so I don't know how to make index.php a default file in the directory, which would probably resolve the problem. That said, does anyone know a work around. I have tried modifiying the base url to no avail.

    Thanks,
    Kevin

  2. davestinner
    Member
    Posted 9 years ago #

    http://www.yourdomain.tld/wordpress/ and http://www.yourdomain.tld/wordpress/index.php are the same. The only thing that would screw that up is if you have an index.htm or index.html file in the same directory as the index.php

  3. KPIZME
    Member
    Posted 9 years ago #

    The only html file in http://www.yourdomain.tld/wordpress/ is the readme file.

  4. davestinner
    Member
    Posted 9 years ago #

    What is your URL?

  5. James
    Happiness Engineer
    Posted 9 years ago #

    In Options/General, "WordPress address (URI)" should be the directory in which all of your WordPress files are located (the directory in which the /wp-admin/ directory resides) and "Blog address (URI)" should be the URL of your blog's index.php file.

  6. MarkMichon
    Member
    Posted 9 years ago #

    Not familier with Windows Server, so if htaccess doesn't exist in that realm this obviously wont work. The following will recognize index.php just like a site recognizes index.html.

    This goes at the top:

    AddType application/x-httpd-php .html .htm .php
    DirectoryIndex index.html index.php

  7. KPIZME
    Member
    Posted 9 years ago #

    Dave, the URL is http://www.kevla.net/wordpress/index.php
    Im playing with Templates now, so you may see it change

  8. KPIZME
    Member
    Posted 9 years ago #

    VERY WIERD. Index.PHP is indeed set as a default. And now everything appears to be ok. Maybe I just paniced because I see index.php was missing from the URL; ie: before the "?" variable qualifier.

    Anyway, thanks for the input...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.