WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "URL File Access is disabled" error? (6 posts)

  1. splwolf
    Member
    Posted 6 years ago #

    I haven't made any modifications to my site in over a week, but this morning, when I checked my homepage, the following error text displayed:

    Warning: main(): URL file-access is disabled in the server configuration in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 5
    
    Warning: main(http://www.franciscancm.org/masthead.php): failed to open stream: no suitable wrapper could be found in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 5
    
    Warning: main(): URL file-access is disabled in the server configuration in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 5
    
    Warning: main(http://www.franciscancm.org/masthead.php): failed to open stream: no suitable wrapper could be found in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 5
    
    Warning: main(): Failed opening 'http://www.franciscancm.org/masthead.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 5
    
    Warning: main(): URL file-access is disabled in the server configuration in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 8
    
    Warning: main(http://www.franciscancm.org/main_menu.php): failed to open stream: no suitable wrapper could be found in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 8
    
    Warning: main(): URL file-access is disabled in the server configuration in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 8
    
    Warning: main(http://www.franciscancm.org/main_menu.php): failed to open stream: no suitable wrapper could be found in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 8
    
    Warning: main(): Failed opening 'http://www.franciscancm.org/main_menu.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/francisc/public_html/wp-content/themes/fcm_2/index.php on line 8

    I've seen similar issues in other threads on the forum, but there doesn't seem to be a blanket solution to this issue. Also, in other cases, this seems to happen because someone was trying to move wordpress or something. I haven't done anything like that (or anything at all).

    My site url is http://www.franciscancm.org

    Does anyone have any idea what might be going on? Since I didn't change anything, I don't have any 'mistakes' to undo, nor a safe configuration to revert to.

    Thanks in advance.

  2. gabrielparriaux
    Member
    Posted 6 years ago #

    Hello Splwolf,

    I have a very similar problem than your...

    I went to see your website and everything seems ok... did you find a solution to this problem? How?

    Thank you for helping...

  3. mellojoe
    Member
    Posted 6 years ago #

    I am having a similar problem. Started a couple of weeks ago. I can't figure it out.

    My site: jpDiMaggio.com

    If anyone can point out a solution, here, it seems that several of us would benefit greatly.

  4. tapos
    Member
    Posted 6 years ago #

    to solve this problem, you have enable allow_url_open in php.ini

    Thanks,
    Tapos Pal

  5. splwolf
    Member
    Posted 6 years ago #

    I didn't solve the problem, per se, but I did find a suitable workaround on another forum thread:

    Check it here.

    It suggests using cURL in place of includes, because there's some security feature enabled on the server. I'm not very knowledgeable when it comes to servers or advanced PHP, so rather than try to rewrite files, this seemed to be a good solution for me.

    For the record, those error messages were only displaying on pages where I had both includes and the wordpress loop running. If I removed either, the problem stopped happening. I hope this helps anyone else with the same problem.

  6. ikester
    Member
    Posted 5 years ago #

    While this post is very old, I noticed that Tapos suggested enable allow_url_open and I am not sure what version of php that relates to but for me using this directive set works most of the time:

    http://us2.php.net/manual/en/ini.php but check with you host to make sure.

    For me the correct directive would be allow_furl_open = true

    Thanks for the help Tapos, I had a similiar problem and your suggestion pushed me in the right direction to find the wrapper problem I was having when updating All in one SEO

    I posted this for anyone who searches this forum and encounter this thread, will see some updated information.

    Adios
    Ike
    [sig moderated]

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.