WordPress.org

Ready to get started?Download WordPress

Forums

URL change in WP Strahorn upgrade (3 posts)

  1. Marc
    Member
    Posted 9 years ago #

    The day Strayhorn was avail I upgraded a test blog from 1.2 Mingus to 1.5. All was well except one item. In dashboard or any other admin page that includes the link to "view site" truncates the URL.
    The original was this http://cranialcavity.net/testblog/index.php

    Now, after upgrade the URL is this: http://cranialcavity.net/testblog/

    I have also upgraded my online blog, also from 1.2 Mingus to Strayhorn and the same problem exists with this blog.

    I understand under "general options" I can change the the URI if I desire to have the blog displayed "different than the directory you installed WordPress in, enter that address here."

    And that's fine for the test blog but with a lot of blogs linking to my online blog it creates alot of broken links that people must change on their end.

    BTW in both upgrades I deleated all files and uploaded fresh Strayhorn files and both were loaded with the identical file structure as original.

    Why did this URL change happen and is there an easy fix?

    Thanks

    UPDATE I should have added, when you use the new truncated URL of the test blog it calls up the header of my main online blog and no posts vice the testblog. No posts obviously because it uses another database.

  2. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Do you have an index.html that is taking precedence over index.php? If so, get rid of it.

    Going to testblog/ should automatically take you to testblog/index.php

    See the last couple posts here:
    http://wordpress.org/support/topic.php?id=10544#post-63271

  3. Marc
    Member
    Posted 9 years ago #

    I agree "going to testblog/ should auto....."

    But it doesn't since the upgrade it would take me to the online blog instead, minus the data because of the different data base. I'm not sure what your link is explaining (Apache) Any way I have solved the problem bychanging the way the URI is saved under "general options" although as I said this creates a problem with all the blogs that link to the main online blog. If another solution isn't found I guess I wil livew with it.

    Is there code for .htaccess that would instruct any browser to go to a list of available URL's? ie
    cranialcavity.net
    cranialcavity.net/wordpress
    cranialcavity.net.wordpress/index.php

    Is this related to the problem? This error is displayed when attempting to "manage files" in this case it was a call to manage the style sheet.

    Warning: file(/home/cranial/public_html/wordpress/Manji2): failed to open stream: No such file or directory in /home/cranial/public_html/wordpress/wp-admin/admin-functions.php on line 908

    Warning: implode(): Bad arguments. in /home/cranial/public_html/wordpress/wp-admin/admin-functions.php on line 908

    When called it displayed the stylesheet but gave this error code to the side under "recent."

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.