WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Urgent - WordPress chaos after attempted update (15 posts)

  1. merrua
    Member
    Posted 7 years ago #

    I was upgrading to wordpress 2.7 and i backed up my 2.2 version, updated the files on the server then went to upgrade.php
    It failed.

    So I reuploaded the old files. Blog was back to normal and tried the upgrade again. Again upgrade failed.

    So this time I deleted everything on the server, rolled back to the orginal state (2.2), confirmed it and ran the update(2.7) again. Again it failed

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    So I went back to my old version (2.2). Now however it wont let me save a post or post. How do I get my old 2.2 version working again? So should i try again with an update.

    Please help I was working on this yesterday to no success. I'm tried everything I could think of.

  2. trisweb
    Member
    Posted 7 years ago #

    Uhh... what versions were those again?

    Correct me if I'm wrong, but WordPress 2.7 doesn't exist. Maybe that's your problem?

    Are you talking about the 2.1 upgrade from 2.0?

    [Edit: 2.0.7 vs 2.0.2 perhaps? Sorry...]

  3. merrua
    Member
    Posted 7 years ago #

    I read on the forums that update.php has the error report when the update fails.

    Should I try to update again and post my error?

    Or am I better off trying to 2.2 working again?

    Anyone have any advice, comments, links anything?

  4. merrua
    Member
    Posted 7 years ago #

    From 2.02 to 2.07. Sorry.
    Should I try again with 2.02 to 2.1? However 2.02 is not working properly, would that carry into 2.1?

  5. spencerp
    Member
    Posted 7 years ago #

    If you want to upgrade to 2.1 please follow these instructions. Also, please make sure ALL of your plugins are compatible with 2.1.

    If they are not listed here, you might want to disable them, that's only if they give you problems. And then contact the plugin author, letting them know to update their plugins.

    And make sure you have MySql version 4.0.0 or higher! If you do not have MySql 4.0.0 or higher, you won't be able to upgrade to 2.1!

    Good luck!

    spencerp

  6. merrua
    Member
    Posted 7 years ago #

    I know those instructions. Plugins are disabled.

    Is there any difference for mysql between 2.02. and 2.07 as well as 2.1
    I have had problem trying to upgrade to either. Internal server errors. Is it mysql?

  7. spencerp
    Member
    Posted 7 years ago #

  8. merrua
    Member
    Posted 7 years ago #

    You said that. I was asking about 2.0.7 to check if that explains my errors.

    I have a host who handles the mysql database so i dont know yet which one we have.

  9. spencerp
    Member
    Posted 7 years ago #

    Oh okay, Well in the last link I posted, Ryan explains what the 2.0.X versions use for MySql..

    2.0.2 to 2.0.7 "Currently requires MySQL 3.23.23 or greater."
    If you're having MySql problems regardless, it's best to contact the host about them.. ? Maybe someone else that's more of a MySql guru can help you better? Good luck either way though! :)

    spencerp

  10. merrua
    Member
    Posted 7 years ago #

    Thank u. I missed that. No guarentee its sql errors. Might be a messed up php file. but i can check my provider.

  11. merrua
    Member
    Posted 7 years ago #

    Checked. I have access to both versions of mysql. Im currently using the old one. That should work for 2.0.2 and 2.0.7

    Just to be clear, I still cant post or save a post in my downgraded wordpress 2.0.2

    Im lost to why.

    Any thoughts?

  12. coders4hire
    Member
    Posted 7 years ago #

    I would recommend backing up and deleting your plugins directory and using the default that comes with 2.1. I did this, ran the upgrade, and it worked. I then had to reactivate each plugin individually.

  13. merrua
    Member
    Posted 7 years ago #

    I'll try that tomorrow if I cant fix this.

    But would that be stopping my old 2.0.2 backup running properly? I dont see why it would. I would really like to find out why I cant post or save before I try to upgrade again in case I just carry whatever problem this is forward.

    Or is best advice upgrade an hope for the best? Thats could be a valid answer but I'm just haven't ran into these problems before.

  14. merrua
    Member
    Posted 7 years ago #

    Deleted plugins. Ran update.php on my 2.0.2 wordpress site. It ran, but I still cant post!

  15. merrua
    Member
    Posted 7 years ago #

    closing this as the name of the thread is confusing.

Topic Closed

This topic has been closed to new replies.

About this Topic