WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
URGENT: Stripe payment gateway not working with subscriptions (5 posts)

  1. CullenJWebb
    Member
    Posted 1 year ago #

    Hello,

    I've tried everything I can think of. Uninstalled the plugin and re-installed in, refreshed the keys, etc.

    The stripe payment gateway comes up just fine when it's in "test" mode. But as soon as I move it out of test mode I get this error on the checkout screen:
    Sorry, it seems that there are no available payment methods for your state. Please contact us if you require assistance or wish to make alternate arrangements.

    We're launching the site this morning and it's super urgent that we figure this out.

    http://wordpress.org/extend/plugins/woocommerce/

  2. CullenJWebb
    Member
    Posted 1 year ago #

    The URL: Zockster.com

  3. Tirano
    Member
    Posted 1 year ago #

    Hello!

    I am getting the same error (Sorry, it seems that there are no available payment methods for your state. Please contact us if you require assistance or wish to make alternate arrangements.) with my e-commerce (woocomerce, gateway pagseguro, correios brasil). Inst working anymore.

    Please help me

    URL : http://www.arkhip.com.br

    thank you
    Carlos Eduardo

  4. CullenJWebb
    Member
    Posted 1 year ago #

    Hey Tirano!

    I can tell you what worked for me.

    Stripe will not work in production mode if you don't have an SSL certificate, AND that the url is secure.

    So first make sure that you have SSL purchased and enabled on your site.

    And second, make sure that SSL is enabled on your WooCommerce settings.

    And thirdly, make sure that you don't have any hard links to the http:// version of the pages. That was my problem.

    I had linked to my products checkout screen via a insecure protocol instead of https://

    You could probably find a plugin to force the use of HTTPS

  5. Tirano
    Member
    Posted 1 year ago #

    Hello Cullen!

    Thank you very much, i set to force the HTTPS and know return to work!

    :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.