WordPress.org

Ready to get started?Download WordPress

Forums

WP Modal Login
[resolved] Always Wrong Credentials Error (15 posts)

  1. therandomguy12345
    Member
    Posted 9 months ago #

    [Topic title moderated. Your issues are no more urgent that anyone else's.]

    @Brainfestation
    @Cole Geissinger

    I am always facing the "wrong credentials" error when trying to login. I have tried with multiple accounts and triple-checked the passwords and this is not a single time occurrence. The same credentials perform properly from default wp-login and wp-admin login pages, so I know that it is some issue to do with the plugin.

    I want to add that I have changed my default login (wp-login.php) and admin (wp-admin) URLs and my default wp-content directory (I am running with over 20 plugins without problem, so this is not the root cause of this issue). I also have my database prefix for wordpress changed from the default "wp_". These are all for security reasons and were accomplished through famous "Better WP Security" plugin found in WordPress.org Plugin Directory.

    This might have something to do with the issue, because the plugin might not be looking in the right location for the login credentials (purely speculation).

    In Better WP Security plugin on the page to hide backend login by changing URL's, it is written:

    Keep this key in a safe place. You can use it to manually fix plugins that link to wp-login.php. Once turning on this feature and plugins linking to wp-login.php will fail without adding ?[the key]& after wp-login.php. 99% of users will not need this key. The only place you would ever use it is to fix a bad login link in the code of a plugin or theme.

    I looked through the files of the WP Modal Login plugin (I'm not a PHP expert or even have intermediate knowledge, so this is pure guess-work) and I saw that in the file titled "class-wp-modal-login.php", there was a reference to the standard wp-login.php. There might be references elsewhere as well.

    I want to also note that I am on a BuddyPress installation (don't think this will be an issue). If the issue is due to the wp-login.php reference, how can I patch it using my secret key, or can you make the plugin compatible/dynamic so no issues will appear?

    Responding as soon as possible would be a huge favor. Thanks in advance. All help is appreciated.

    with regards,
    therandomguy12345

    http://wordpress.org/extend/plugins/wp-modal-login/

    [No bumping. If it's that urgent after just 17 minutes, consider hiring someone.]

  2. Cole Geissinger
    Member
    Plugin Author

    Posted 9 months ago #

    Hi theres,

    All references to any core WordPress file, the plugin is using WordPress' functions to return your setups correct path to those files so nothing is hardcoded except for the file name itself which shouldn't be an issue.

    However, it is possible there is something going on with that type of setup that is 'causing the plugin to break. The error messages are all done with Ajax so it's possible there's a JavaScript error stopping the script from running correctly. Do you have a URL to a site I can check some things?

    I will also test this out with a modified file structure like yours and see if I can uncover anything. Work has me tied down and with WordCamp SF coming up, my time is slim, but I might be able to check this out by Sunday at the latest.

  3. therandomguy12345
    Member
    Posted 9 months ago #

    Can you provide an email address? I don't want to publicly post my URL, because website is still under development. I can give you temporarily changed admin credentials if needed and multiple user credentials for testing. I'll email you any information you request. Please respond as soon as possible.

  4. Cole Geissinger
    Member
    Plugin Author

    Posted 9 months ago #

    You can email that information to coke (at) colegeissinger.com

  5. Cole Geissinger
    Member
    Plugin Author

    Posted 9 months ago #

    Cole not coke** autocorrect :P

  6. therandomguy12345
    Member
    Posted 9 months ago #

    I just emailed you. Reply when you receive (since it has important/secret information)

  7. therandomguy12345
    Member
    Posted 9 months ago #

    @Brainfestation
    @Cole Geissinger

    I sent you some follow-up information on the issue at hand. It's not yet resolved. I've been trying to reach you. I know that you are probably held up with WordCamp San Francisco, but please confirm that you have received my latest email message (it contains all needed information - so I started new thread - since old one was getting excessively large).

    Sorry if I'm being kind of pushy. I want to say that you have done an excellent job with WP Modal Login and I can't wait until it'll be usable and functioning properly on my WordPress website! All the support and enthusiasm to help that you have provided so far has been wonderful. Please respond to my latest email as soon as possible (it contains all information needed - including that from previous thread in attached Word document). All help is appreciated.

  8. Cole Geissinger
    Member
    Plugin Author

    Posted 9 months ago #

    Hi therandomguy12345

    I have received your emails and have replied back that I received them.

    Please keep in mind that my schedule is very busy and I do not make any money on this plugin, so I am only able to offer my help when I can.

    Sunday I will have time to take a look and see what's going on. I'll double check that everything you provided gets me what I need to assist you further.

  9. therandomguy12345
    Member
    Posted 9 months ago #

    @Brainfestation
    @Cole Geissinger

    Okay thx. Sunday will be fine with me! Just make sure that you received my latest email that I composed this morning with the Word Document attached (it was in a new thread, not from the old thread -- it has two emails -- 1st one has real information to pay attention & 2nd one was just a request for faster support, but don't bother - I understand your situation and appreciate help on Sunday).

    The email had the Subject: "More Information -- Always Wrong Credentials Issue" and I emailed it to your [ redacted, do not post other people's e-mail adddresses ] & your Gmail account that you responded to all my emails using. I sent it to both, because I didn't know which one was the appropriate one to use to contact you. To make it easier to find, I started a new thread for this email. The attached Word Document contained all information necessary from my original threads + a little new information that might help. I also included information about possible conflicts with the WP Modal Login Plugin and other setups on my server -- Important Information. If you didn't receive this email, I can resend it - just notify me via email or through this support thread.

    Thx for all the help. It's really appreciated. Remember to check for the newly composed email with details and tell me if you received it via a reply to that email (it's a new thread) or via this post.

    NOTE: Please disregard the request to help as soon as possible -- i understand your circumstance now -- just pay close attention to the attached document and details about other plugins and setup in the body of the email message. I requested this in the second message (first reply) of my newly started email thread and in the first email -- disregard both. Sunday will work and I really appreciate your willingness to help.

    with regards
    therandomguy12345

  10. Stepping in for a moment...

    Remember to check for the newly composed email with details and tell me if you received it via a reply to that email (it's a new thread) or via this post.

    @therandomguy12345? I think you may want to re-read this part from the plugin author.

    Please keep in mind that my schedule is very busy and I do not make any money on this plugin, so I am only able to offer my help when I can.

    Plugins and the support of plugins is performed and offered as part of a free community service on the plugin author's part.

    In plain English? Please give these guys some space. ;)

    When they get back to you is up to them. If that's Sunday that's great. If not then be patient and consider that your emergency may not have the same urgency to them.

    I now return you to your regularly scheduled support thread. ;)

  11. therandomguy12345
    Member
    Posted 9 months ago #

    @Jan Dembowski
    My apologies. You do make a good point, but I wanted to clarify something about my statement.

    Remember to check for the newly composed email with details and tell me if you received it via a reply to that email (it's a new thread) or via this post.

    I wanted to make sure that the email went through (hence, I was also confused about the email address to send follow-ups to -- it was a new email thread, not support thread), because it contained key details. I'm sorry for sounding pushy, but I didn't really have those kind of intentions.

    Also, I see that my post before this was moderated:

    [ redacted, do not post other people's e-mail adddresses ]

    I don't think that was a problem since Cole himself posted that earlier in this thread.

    You can email that information to coke (at) colegeissinger.com

    Cole not coke** autocorrect :P

    Anyways, I really do apologize to both Cole & you. It's just that I wanted to make sure that since I sent important details, such as admin information and more, it was received and not incorrectly sent. Sorry for the mis-communication and my pushy-ness.

    @Brainfestation
    @Cole Geissinger
    I really do apologize, too. You can help me whenever you please, but do contact me when the issue is resolved, so I can change my temporary admin details and test results. I really appreciate you working with me and sorry for any discomfort/inconvienience that I have caused.

    And don't worry — I'm not expecting you to respond or anything to this message (like I was previously requesting with my emails). Whenever you get a chance, you can provide support. If you can't, you can't and it's fine because it was a favor. If you can, it's really appreciated (even if it's not by Sunday). Have a nice day! :)

    with regards
    therandomguy12345

  12. Cole Geissinger
    Member
    Plugin Author

    Posted 9 months ago #

    Hi therandomguy12345

    Found the issue was do to some security checks on the password when passed through. It was stripping out special characters. I have since fixed and released a new update that also offers Spanish translations thanks to a very generous community member :)

    Once you have confirmed everything is working on the new version I'll be sure to to delete out the emails you sent that contain your login info and other stuff.

    Thanks

  13. therandomguy12345
    Member
    Posted 9 months ago #

    @Brainfestation
    @Cole Geissinger

    Thanks, Cole! You're the best! It did exactly what I was hoping for.

    New version is absolutely phenomenal!

    Please do delete the emails with information about my website (all the ones I sent you). I'll change my credentials anyways. I trust you though.

    Thanks so much! You really saved my day!

    with regards
    therandomguy12345

  14. Cole Geissinger
    Member
    Plugin Author

    Posted 9 months ago #

    Awesome! Glad I could help and the plugin brings what you are looking for in your site. Plus, you helped me uncover a bug :) Always good to squash those! Happy WordPressing!

  15. therandomguy12345
    Member
    Posted 9 months ago #

    @Brainfestation
    @Cole Geissinger

    Thanks. Really appreciated your help on last issue. I'm glad I helped too! I have one more question (on non-related subject -- not urgent at all)

    I just added a new topic asking if it was possible to make WP Modal Login compatible with the redirect caused by the below plugin:

    http://wordpress.org/plugins/bp-redirect-to-profile/

    or the below code snippet (same as plugin):
    http://buddydev.com/buddypress/buddypress-trick-redirect-users-to-their-profile-on-login/

    I added that this was not at all an urgent issue, because it really isn't. It would just be nice if whenever you found free time, you could give it a shot.

    For some reason, I was notified that my topic was removed or something??? Little confused about this. Just take a look whenever you get a chance. If there was something that I did wrong, just tell me. If it was something else, please tell too. It might have been that the topic wasn't completely posted, but just some connection error in process or something

Reply

You must log in to post.

About this Plugin

About this Topic