WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upon enabling multisite and re-logging in get 500 Internal Server Error (10 posts)

  1. dgroos
    Member
    Posted 3 years ago #

    Unable to resolve my previous issue with my wordpress 3.0.1 sites, I decided to do a fresh install of 3.0.1.

    I just went through the basic wordpress install page and everything went fine. Then I went to enable multisites as per the Create A Network page. I used the sub-directory method as I met these qualifications. Everything went fine till the very last instruction to log back in. I was taken to a 500 page:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache/2.2.3 (Red Hat) Server at My-site-address 80

    I tried for several hours to fix it to no avail. Finally I removed the database and wp install, and did a fresh reinstall, very carefully, but received exactly the same error. I had changed permissions of .htaccess and blog.dir to 666. The error log produces these every time I try to reload the page:

    [Sat Nov 27 21:52:52 2010] [alert] [client x.x.x.x] /var/www/html/blog/.htaccess: RewriteRule: bad argument line '^([_0-9a-zA-Z-]+/)?files/(.+)', referer: http://my-domain-address/blog/wp-admin/network.php
    (I've changed the client ip and domain address to generic values)

    The info in the .htaccess file was of course copied from the lines of code created for me on the 'enabling the network' page. Yes, I cleared the cache and cookies of my browser as suggested. I'd really appreciate any help here.

    David

  2. dgroos
    Member
    Posted 3 years ago #

    Perhaps I should add my .htaccess file content:

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+)
    wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    David

  3. What are using for a text editor? On a Mac or PC? And a linux or Windows server?

  4. dgroos
    Member
    Posted 3 years ago #

    I'm accessing the webpage via most recent firefox on my mac. The server is the districts redhat linux, I'm doing all text editing via ssh with nano. This same install has been running a wordpress 3.0.1 site.

    So, I copied the code that was generated for me in firefox web page and pasted that directly (not using TextEdit) into the terminal running nano.

    Thanks for engaging this issue songdogtech!

  5. And is mod_rewrite enabled on the server?

    Are ya logged in as root making that htaccess file? ;)

  6. dgroos
    Member
    Posted 3 years ago #

    Hi Andrea,

    I assume mod_rewrite is enabled on the server since I had a multi-site wp 3.0.1 functioning on it before...

    I have to 'sudo' to do any work on the server. I changed chmod to 666 and chown to (33:33) to obtain what appear to be proper owner/group, at least that's the ownership on basically everything in the wp install.

  7. taking a quick look, it looks like the line for Uploaded Files has an extra line break in it. Try this?

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
  8. But it can be enabled on the server and disabled on that web account. :)

  9. dgroos
    Member
    Posted 3 years ago #

    :D
    I threw salt over my left shoulder, deleted the old database, and instead of copying and pasting what you wrote I dragged and dropped it directly into the ssh/nano window of the file and... it worked!:D

    Not sure what all did it so, songdogtech, Andrea_r and ipstenu, Thanks much for your help! I've got a functioning site which I'm about to back up. After which, I'm going to try to import in my old site as per Andrea_r recommendation here.

    David

    Just kidding about the salt over the left shoulder. It was the right one ;)

  10. Whatever voodoo tricks work. :) I mean, my desk is pretty dented from banging my head into it, so I don't do that anymore. :D

Topic Closed

This topic has been closed to new replies.

About this Topic