WordPress.org

Ready to get started?Download WordPress

Forums

Uploading site file that is bigger than maximum allowed (6 posts)

  1. iowagirleats
    Member
    Posted 5 years ago #

    I am moving from a wordpress.com blog to a wordpress.org blog and I have 2 questions that I can't find the answer to:

    1. How do I make sure my .xml file export from wordpress.com contains all images?

    2. My current wp.com export is 13.7MB and the max file upload size is 7MB. How do I get my file imported? Can I break it up? Do I need to use an ftp client? If so, at what folder level do I import my .xml file?

    Thanks!

  2. Matt Rude
    Member
    Posted 5 years ago #

    1. it's not a problem, the xml file only tells your new install where the files live on the internet, it will download them during the upgrade.

    2. you will need to talk to your hosting provider, they will need to increase your php upload_max_filesize

  3. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Check with these options:

    2. If you have an access of PHP.ini file of the account/server then change the line in PHP.ini where line shows 32M to 64M:
    upload_limit = 128M;

    3. If you do not have access of PHP.ini file then add this to an .htaccess file of your domain:
    php_value upload_limit 128M

    4. Try to add this line to your wp-config.php file to increase allocated upload limit to PHP:
    define(’WP_UPLOAD_LIMIT’, ‘128M’);

    If all this option can not resolve the issue then you need to contact your hosting service provider to resolve this issue.

    Thanks,

    Shane G.

  4. iowagirleats
    Member
    Posted 5 years ago #

    So I increased the max file size to 30B, but when I try and import my .xml file, I get all the way to "assigning authors and import attachments" then I get the following error in wordpress:

    The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Apache/1.3.33 Server at iowagirleats.com Port80

    Then I also get a pop up error in my file account manager in my hosting account (Go Daddy) that says:

    There was an error processing your request. Additional details are in the server logs.

    Yesterday they had me add the following string to my php.ini file to increase my max upload file saize, and rename it to php5.ini:

    memory_limit = 50M
    post_max_size = 100M
    file_uploads = On
    upload_max_filesize = 30M

    I'm thinking the error maybe has something to do with this?

    THANK You!!

  5. brettbum
    Member
    Posted 4 years ago #

    I'm running into this same error attempting to import data from a WP 2.9.2 install to a new 2.9.2 install (that I will be using for test).

    Never run into this problem and have configured many different test accounts on this particular host/server before. The file size I'm having problems with is 16.7mb.

    I've uploaded that size of a site file before on this server also (bigger even).

    So far I've attempted the wp-config change option suggested above and waiting to see if that works (going very slow)

  6. brettbum
    Member
    Posted 4 years ago #

    using the define in the wp-config option I got a nice little 500 error

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@ my site .com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Topic Closed

This topic has been closed to new replies.

About this Topic