WordPress.org

Ready to get started?Download WordPress

Forums

Uploading media IIS7 problem! (4 posts)

  1. alespinola
    Member
    Posted 4 years ago #

    Hi all!
    My environment:
    Windows Server 2008
    IIS 7 with Rewrite module 2.0 beta
    Wordpress MU 2.8.4

    Well, I'm having a rewriting problem I guess... The thing is that I can upload things to the server, but then, I can't access that media.
    My browser is looking for the uploaded files in:
    http://test.my.domain.com/files/2009/09/New-Text-Document.txt
    If I copy that URL and paste it in the browser, I get a 404 not found error because the server is looking for the file in a wrong place.
    I have a rewrite rule in my IIS but it is not working or it's working in an unexpected manner.
    The rule is the following:

    <rule name="wordpress - 2" stopProcessing="true">
                        <match url="^(.*/)?files/(.*)" />
                        <conditions>
                            <add input="{REQUEST_URI}" pattern=".*wp-content/plugins.*" negate="true" />
                        </conditions>
                        <action type="Rewrite" url="wp-content/blogs.php?file={R:2}" appendQueryString="false" />
                    </rule>

    Everything else is working just fine, permalinks, posts, new blogs, etc. But I can't work with uploaded media...
    Any ideas?

  2. ryans149
    Member
    Posted 4 years ago #

    what is your upload path ?

    check here:

    settings --> Miscellaneous

  3. alespinola
    Member
    Posted 4 years ago #

    Uhm.. don't have that option in Worpress Mu... or at least I can't find it..

  4. arnocs
    Member
    Posted 4 years ago #

    upload path location has changed

    Settings --> Media [Uploading Files] - Store uploads in this folder

Topic Closed

This topic has been closed to new replies.

About this Topic