WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Uploading media - http error (7 posts)

  1. Luraguttn
    Member
    Posted 2 years ago #

    After i upgraed to 3.3 of wordpress, my media uploader has been defect. Whenever i try to upload an image, i get an http error. Some image is working, and some is not. I am not sure of why. I have been doing a fresh install, and still the same error. When i tryed to upload 15 images, 10 got uploaded, and on the rest i got the "http error". The images i try to upload are all .png images, i tryed to change it from png, too jpeg and see if that was the problem. I don't just get why some images get uploaded, and some of em not. Is there anyone that has the same problem, or knows how to fix this?

    First error image:
    First error image

    Second error image

    Anyone?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. Luraguttn
    Member
    Posted 2 years ago #

    Hello, esmi.

    I have been trying to read the masters list, but i am not seeing anything related too my poblem....

  4. buraksepici
    Member
    Posted 2 years ago #

    Hello,

    I'm having the exact same problem. Additionally, when I use the HTML uploader I get a 500 Internal server error...

    There is a more specific catch though, when I upload anything smaller than 120 KB (it seems), it gets uploaded without any issues. For example when I upload 25 files with varying sizes, each one under 120 KB gets through, but ones larger than 120 KB fail...

    Any ideas anyone?

  5. buraksepici
    Member
    Posted 2 years ago #

    OK, admittedly that was quick by me :) I found out that my issue was related to the domain settings in the server, namely PHP being run as a FastCGI application. When reverted to Apache Module all is well now...

    Luraguttn if you have access to your hosting server, check if your domain is set to use PHP as FastCGI or an Apache Module...

  6. Luraguttn
    Member
    Posted 2 years ago #

    Love you, buraksepici! Work as a dream!

    Have a nice christmas, and a happy new year!

  7. noxion
    Member
    Posted 2 years ago #

    Solution after Media Temple upgrates on Plesk and PHP.

    Edit the following file:
    /etc/httpd/conf.d/fcgid.conf

    Add this line (just below all of the other lines that start with ‘Fcgid’):

    FcgidMaxRequestLen 1073741824

    Restart your Apache web-server service with this command:

    service httpd restart

    Yey!

Topic Closed

This topic has been closed to new replies.

About this Topic