WordPress.org

Ready to get started?Download WordPress

Forums

[closed] uploading images to wordpress 3.3 (50 posts)

  1. vivikew
    Member
    Posted 2 years ago #

    Hi, would like some help and advise.
    ive just upgraded to wordpress 3.3 my nextgen gallery version 1.9.1

    1. i tried to upload images into existing gallery but the images are not loading.
    tried creating a new gallery to upload these images, it is still the same.

    2. under my nextgen gallery options,

    general options
    thumbnails
    images
    gallery
    effects
    watermark
    slideshow

    when i click thumbnail, the general option page appears
    when i click images, the thumbnail page appears
    when click on slideshow, watermark page appears leaving no slideshow page to click for edit.

    could someone help to advise to rectify the above two problem. thanks an appreciate

    vivi

  2. Alex Rabe
    Member
    Posted 2 years ago #

    do you see any script error in your browser ?

  3. vivikew
    Member
    Posted 2 years ago #

    hi alex, thank you for the reply.

    there is no script error appearance.
    after i upload the pictures, it just goes back to the options page.

    pls help. thanks vivi

  4. Alex Rabe
    Member
    Posted 2 years ago #

    Can anybody else report the same ? can't reproduce it

  5. gelineeweenie
    Member
    Posted 2 years ago #

    yes, i'm having problems too. when i try to upload an image on a post, the pop-up window doesn't work. The window never loads!

  6. RichardWPG
    Member
    Posted 2 years ago #

    do u use the drag and drop feature?

  7. vivikew
    Member
    Posted 2 years ago #

    I have reverted to wp 3.2.1
    however the same problem still exists.

    under my nextgen gallery options,

    there is

    general options
    thumbnails
    images
    gallery
    effects
    watermark
    slideshow

    when i click thumbnail, the general option page appears
    when i click images, the thumbnail page appears
    when click on slideshow, watermark page appears leaving no slideshow page to click for edit.

    can anyone help on this?

  8. Pete Lo
    Member
    Posted 2 years ago #

    Yes, I've been replicating something very similar!

    I upgraded to WP 3.3 18 hours ago then I got started trying to upload images but it would only upload them if they were approx 1-2MB. Anything over 4MB would not upload and came up with the error message:

    Fatal error: Out of memory (allocated 68681728) (tried to allocate 12672 bytes) in /home/xxxxxx/public_html/wp-includes/media.php on line 258, or similar.

    Tried to use their new browser uploader and also alternatively upload them via a slideshow plugin I've just installed and neither made any difference.

    Long story short after many options tried, and doing what Hostgator advised (directly uploading images to varies content files via their Control Panel) all still to no avail and same error message within WP when you go to where you installed them. CP uploaded them properly (although it took a lot of time) but when I went to where they were in WP the image just hadn't loaded up, (despite being located on that folder in CP), and the error message was still evident.

    Hostgator has advised this is a programming error and we need to ask WP for a fix, as they've tried to help many with similar problems but still to no avail. (...and yes they put php.ini at 128MB on my account).

    Does anyone know how to revert back to 3.2.1, and if it solved the problem.

    (Is it me or don't you just hate upgrading when the damn thing isn't fully working perfectly?!! I actually trusted WP to not do that to us as well! Duh!).

  9. BenjiSlayer
    Member
    Posted 2 years ago #

    Hello.

    I just upgrade my wordpress to 3.3 a few hours ago, and I have a similar problem.

    When I upload an image, all works well, there is no script errors too, but the image doesn't appear.

    I checked the directory with my ftp-client and the image appears in the site!, but it has size of 0kb. I tried to change the permissions (but they already had to 777).

    Thanks for the help.

  10. mjwillis
    Member
    Posted 2 years ago #

    Similar problem with 3.3. I can upload the image using New media (don't see anything about drag and drop when I do this), but when I try to insert an image into a post I get the black screen with the start of uploading (the rectangular box that shows it's searching), then the box goes away and I'm left with a black blank screen and no way to upload a image from anywhere. I click on the blank screen and it takes me back to the post.

  11. Alex Rabe
    Member
    Posted 2 years ago #

    Ok , the upload method has change under WP3.3, please report back which browser do you use and if possible test it as well under a other browser. I'm looking into this

  12. mjwillis
    Member
    Posted 2 years ago #

    I use Mozilla Firefox as my primary browser. As you suggested I opened Explorer and tested the upload image icon in Post edit and it worked fine. Hope that information helps.

  13. Pete Lo
    Member
    Posted 2 years ago #

    Hiya Alex,

    I can confirm it's not loading 4-5MB photos in IE 8.

    I don't use any other browser.

    Cheers.

  14. BenjiSlayer
    Member
    Posted 2 years ago #

    I use Google Chrome

    I will test in Firefox and IE8,

    Lets check

  15. Alex Rabe
    Member
    Posted 2 years ago #

    @Pete Lo : Try to use the new scale down option (resize) before you start upload

  16. Read http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

    Follow the steps for turning off plugins but also, especially if you use Firefox, empty your browser's cache.

  17. Pete Lo
    Member
    Posted 2 years ago #

    @ Alex : Where is the new "scale down option" before I start to upload?

    All I have is 2 options to upload photos.

    1. Media > Add New > Select Files > Open a photo from PC ...which then lists the jpeg in the upload media section and results in:
    Fatal error: Out of memory (allocated 68681728) (tried to allocate 19008 bytes) in /home/xxxxxx/public_html/wp-includes/media.php on line 258 when showing 100% in right hand box

    2 Media > Add New > Browser Uploader link > Browse > Open a photo from PC > Upload > takes a good 30 seconds to try and load and stops this time, then displays exactly the same error as above: i.e.
    Fatal error: Out of memory (allocated 68681728) (tried to allocate 19008 bytes) in /home/xxxxxx/public_html/wp-includes/media.php on line 258

    ..but displays this on a white web page and we have to hit the back button to get back into WP.

    So where is the new scale down option to resize a photo before Selecting it or Opening it, exactly?

    The two plugins I have are deactivated whilst I'm doing this. Photos are Jpegs 4-5MB in size, and we should be able to upload a maximum file size of 64MB to store in the library ...so uhm, any ideas?

  18. BenjiSlayer
    Member
    Posted 2 years ago #

    I already deactivated all the plugins and the problem isn't solved

  19. BenjiSlayer
    Member
    Posted 2 years ago #

    I tested in firefox (latest version) and IE8 too. And the problem continues...

    Some other solution?

  20. Alex Rabe
    Member
    Posted 2 years ago #

    @Pete Lo : sorry for confusing , I'm talking about NextGEN Gallery plugin and not the general core media upload

  21. Pete Lo
    Member
    Posted 2 years ago #

    @ Alex : Oh, ok. ...Why talk about a plugin instead of making the core WP media upload system upload up to the max specified 64MB, when it's not uploading even 5MB? You kinda lost me there.

    The only 2 plugins I have are the All in one SEO Pack and GRAND Flash Album Gallery, so yes I've tried uploading them through that gallery plugin and it didn't work. Same problem, unfortunately.

    I've also uploaded them DIRECT to wp-content via Hostgator's Cpanel BUT they are not loading fully in the library, and when you click on View the error code displays.

    I've also uploaded a few test 5MB photos via CP into the flash gallery plugin ..so I doubt NextGEN would differ ...but I'm guessing the key here you're getting at is in resizing them first so they are under 4MB, yes? Or better still, much nearer to 1-2MB if poss if it doesn't lose quality, so I'll give it a whirl and come back and report.

    (Of course, you're completely sidestepping making your core media upload system work properly in this 3.3 upgrade, but hey if it gives some of us a work around for a while then let's test it).

    Back soon...

  22. Pete Lo
    Member
    Posted 2 years ago #

    Hiya Alex,

    Yes, happily I can confirm that your resizing sidestep before uploading photos by using the NextGEN plugin, and then uploading them through that plugin's interface and not via WP's core media uploading system, has worked in uploading the photos I have that were all originally 4-5MB in size. ...and they've fully loaded in that plugin's library space.

    Cool.

    So there you have it folks. A temporary sidestep to try whilst WP programmers figure out what's going on with their uploading bug in this new 3.3 upgrade.

    And, even better, when they do finally fix the bug, you'll still be operating on 3.3 and won't have to move your photos anywhere, unless you really want to via your Cpanel.

    Cheers Alex.

  23. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    What bug? There is a 2MB limit on file size using the wp flash or html uploader. The uploader clearly states the limit so why would you expect to be able to load in excess of that?

    Just trying to understand not stir the pot.

  24. Pete Lo
    Member
    Posted 2 years ago #

    @kmessinger :

    In my WP 3.3 upgrade under media > add new > upload new media, it says:

    "You are using the browser’s built-in file uploader. The new WordPress uploader includes multiple file selection and drag and drop capability. Switch to the new uploader.

    Maximum upload file size: 64MB. After a file has been uploaded, you can add titles and descriptions."

    So my WP 3.3 media uploader 'clearly states the limit' on file size as up to 64MB, so that's why I expected to be able to upload a mere 5MB photo with no probs when I upgraded.

    And it would only upload my 1-2MB file size photos hence me coming here.

    Makes sense? ...and Alex has sorted a sidestep way of uploading for now whilst they look into it. See above.

  25. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Mine says (on 3 different sites all upgraded to 3.3 and have run the beta and rc versions).

    Upload New Media
    You are using the multi-file uploader. Problems? Try the browser uploader instead.

    Maximum upload file size: 2MB. After a file has been uploaded, you can add titles and descriptions.

    If you switch to twenty eleven do you get the same message?

  26. Pete Lo
    Member
    Posted 2 years ago #

    @kmessinger

    Yes. I've just switched my theme to Twenty Eleven for you and activated it and it still says exactly the same in media > add new > upload new media. i.e.

    "You are using the browser’s built-in file uploader. The new WordPress uploader includes multiple file selection and drag and drop capability. Switch to the new uploader.

    Maximum upload file size: 64MB. After a file has been uploaded, you can add titles and descriptions"

    I would have thought it would be the same for everyone else who is on WP 3.3 no matter what theme folks are using so I haven't a clue why yours is showing 2MB max file upload size, and not the normal 64MB.

    ...but if you want to see how I've managed to use Alex's sidestep tip using the NextGEN plugin and resizing my 5MB photos automatically by just ticking a box before uploading them then just go here for proof - http://fyldevintageandfarmshow.co.uk/gallery/

    I'm in the process of uploading and altering things now so am happy enough to finally get my images up. Been a frustrating 30 hours, lol.

    Hope this helps anyone. Ciaooo for now..

  27. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Actually, http://codex.wordpress.org/Inserting_Images_into_Posts_and_Pages shows a 1GB maximum for wp 3.3

    Themes do mess with the backend. I ran 3.3 on 8 different themes with no problems but then I did not try to upload large image files. I will replace some files and see if I can get the limit as per the Codex.

  28. Dakota XT
    Member
    Posted 2 years ago #

    I am having similar problems. On trying to upload a new image, when clicking the upload media icon nothing happens. On trying to edit an image in an existing post, the screen dims but nothing happens. I can however upload images through the Media up-loader (but not insert them through the visual editor into the posts).

    I have switched back to the Twenty Eleven theme, turned off the one plugin I am using, cleared my cache, contacted the server techs to update all the PHP libraries.

    My husband is getting an error message in Firebug saying "Postboxes is not defined". I am using Firefox 8.0.1, IE 8 and Chrome 16.0.912.63 m.

    Looking around the forums, this is a known issue. Is there a fix or workaround for those affected yet?

  29. Kerim
    Member
    Posted 2 years ago #

    I have the same issue. I'm using the latest version of Chrome for OS X. The button and alternative link on the "upload new media" page simply don't do anything.

  30. werlisa
    Member
    Posted 2 years ago #

    I think we can confirm that it is a mistake of the last update of wordpress, I can not wait to find a solution on this forum and I had to pay to fix this inconvenience ... I am receiving many complaints from my customers!

    They use a form to send his images but now these images are not attached in the post that my clients have created .. a disaster.

    When I find a solution I will try to share.

    Regards

Topic Closed

This topic has been closed to new replies.

About this Topic