WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Uploading images I am getting an error 3.5.1 WordPress (19 posts)

  1. rickmick
    Member
    Posted 1 year ago #

    I am using 3.5.1 WordPress when I try to post a picture to my post and upload it I get this error. "An error occurred in the upload. Please try again later." The picture does not show in my library until I dismiss the error and do a search. I can then post it. I have reverted back to 3.4 WordPress. I have changed my theme to several different ones. I have deactivated all my plugins. I can go to Media in the admin panel and see my picture in the library. If I try to upload a new image it just shows full crunching and nothing else until I switch to the library and then it shows it.

    I can't seem to work this problem out. I am using FireFox

  2. Jess
    Member
    Posted 1 year ago #

    This sounds like a memory problem on your server. Have you looked at the server logs? What error messages appear there?

  3. rickmick
    Member
    Posted 1 year ago #

    This is my error log from Hostgator. It looks like they are from spam referrers. Thanks,

    [Tue Feb 19 15:01:55 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/
    [Tue Feb 19 15:01:55 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/
    [Tue Feb 19 15:01:55 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/
    [Tue Feb 19 15:01:55 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/
    [Tue Feb 19 15:01:55 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/newthread.php?fid=2
    [Tue Feb 19 15:01:55 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/newthread.php?fid=2
    [Tue Feb 19 15:01:54 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/newthread.php?fid=2
    [Tue Feb 19 15:01:54 2013] [error] [client 178.32.97.118] client denied by server configuration: /home/rickmick/public_html/newthread.php, referer: http://rickmick.com/newthread.php?fid=2
    [Tue Feb 19 15:00:04 2013] [error] [client 110.84.210.156] File does not exist: /home/rickmick/public_html/newthread.php, referer: http://rickmick.com/newthread.php?fid=2
    [Tue Feb 19 14:52:01 2013] [error] [client 65.55.213.59] File does not exist: /home/rickmick/public_html/us-navy\xe2\x80\x99s-future-map-of-the-united-states, referer: http://www.bing.com/search?q=future+of+united+states&form=MSNH14&sc=8-4&sp=-1&qs=n&sk=
    [Tue Feb 19 14:51:39 2013] [error] [client 119.63.196.94] File does not exist: /home/rickmick/public_html/showthread.php
    [Tue Feb 19 14:44:29 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:44:29 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:44:29 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:44:29 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/index.php, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:43:51 2013] [error] [client 216.99.157.210] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:43:51 2013] [error] [client 216.99.157.210] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:43:51 2013] [error] [client 216.99.157.210] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:43:51 2013] [error] [client 216.99.157.210] client denied by server configuration: /home/rickmick/public_html/index.php, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:42:26 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:42:26 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:42:26 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:42:26 2013] [error] [client 216.99.144.82] client denied by server configuration: /home/rickmick/public_html/index.php, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:32:53 2013] [error] [client 108.171.251.114] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:32:53 2013] [error] [client 108.171.251.114] client denied by server configuration: /home/rickmick/public_html/, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:32:53 2013] [error] [client 108.171.251.114] client denied by server configuration: /home/rickmick/public_html/403.shtml, referer: http://rickmick.com/index.php
    [Tue Feb 19 14:32:53 2013] [error] [client 108.171.251.114] client denied by server configuration: /home/rickmick/public_html/index.php, referer: http://rickmick.com/index.php

  4. Umair ul haq Usmani
    Member
    Posted 1 year ago #

    This is the solution..... hope you will enjoy

    You can change that setting by making a simple text file and putting it into the wp-admin folder.

    So to make this file all you have to do is open a simple text program like textedit on Mac or notepad on Windows and type these two lines of code.

    upload_max_filesize = 64M;
    post_max_size = 32M;

    You can put in any value you want I just chose 64 and 32 because they seemed like good numbers. So now you just save the file and name it php.ini the program will ask you if you want to use the ini extension, click use ini and save. Now all that is left to do is upload the file to your server and place it in the "wp-admin" folder, anywhere in the root section of the folder is fine.

    Now login to your WordPress control panel and try and upload something large. It shouldn't give you any problems and upload whatever you want!

  5. Jess
    Member
    Posted 1 year ago #

    On many hosting packages, this file is automatically generated, so look to see if one exists on your server before creating a new one.

  6. rickmick
    Member
    Posted 1 year ago #

    Umair, thanks for the reply. I tried doing what you said and it is still doing the same thing.

    I looked at my php.ini on Hostgator and they seem to be OK.
    memory_limit 256M
    upload_max_filesize 64M

    It worked just fine the day before it started. The night before I updated NextGEN Gallery. I also deleted it and reverted back to the previous version. I can upload image just fine using NextGEN Gallery

  7. rickmick
    Member
    Posted 1 year ago #

    Thanks, Jess this is the only errors I could find on my server. I tried uploading images to my post. The errors below show up. This is not the images that I am trying to upload. I had tried to upload an image named bg.gif earlier. I'm not sure way it keeps trying to upload it.

    [Tue Feb 19 16:39:12 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg4.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:39:12 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg5.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:38:57 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg4.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:38:57 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg5.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:36:58 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg4.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:36:58 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg5.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:36:35 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg4.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edit

    [Tue Feb 19 16:36:35 2013] [error] [client 75.120.146.43] File does not exist: /home/rickmick/public_html/wp-content/uploads/2013/02/bg5.gif, referer: http://rickmick.com/wp-admin/post.php?post=8525&action=edi

  8. Jess
    Member
    Posted 1 year ago #

    Personally, I would do a manual reinstall of WordPress to clean out anything left behind by the NextGEN gallery plugin. See this page for details: http://codex.wordpress.org/Updating_WordPress#Manual_Update

    Then try uploading images with NO plugins running, and using the Twenty Twelve theme. If everything works there, then re-activate your current theme and test it again. If everything still works, then start re-enabling your plugins one at a time to see if there is something causing a conflict.

    If it still doesn't work with a FRESH install of WordPress, then I would contact your host. There is also the possibility that something is wrong with the database, but that's not my expertise, so hopefully someone else can chime in and help with that if necessary.

  9. rickmick
    Member
    Posted 1 year ago #

    I have already tried that. Nothing works. I even deleted my wp-content folder. It must have did something to my database.

  10. rickmick
    Member
    Posted 1 year ago #

    I have noticed that the browser’s built-in file uploader uploads without any problems.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    What happens if you use another browser? Another computer?

  12. rickmick
    Member
    Posted 1 year ago #

    Thanks esmi, I tried it on my Ipad and it is doing the same thing.

  13. rickmick
    Member
    Posted 1 year ago #

    I created a new 3.5.1 WordPress,in a sub-directory. I also created a new database,and everything was default. I tried uploading an image and I am still getting the same error.

    I created a new 3.4 WordPress,in a sub-directory. I also created a new database,and everything was default. I tried uploading an image and it only shows full Crunching… and nothing else. The gallery shows the image.

    Could it be my ISP or Hostgator? I usually can work problems out on WordPress, but I am lost with this.

  14. Jess
    Member
    Posted 1 year ago #

    Definitely have a talk with Hostgator and see if they can see anything that you can't. Because if you're getting this behavior with a clean install, then it's not WordPress that is the problem, but rather the way your host and WordPress interact.

  15. rickmick
    Member
    Posted 1 year ago #

    Here is the response from HostGator

    Hello,

    Thank you for contacting HostGator. I have tweaked the settings of your user's apache rlimits and php settings to the maximum available on our shared servers. The images are still not uploading. I am seeing a large amount of plugins configured on your WordPress and those plugins will eat up the available 256mb of php memory and then each process to upload the files and crunch the images will add to it. In this instance you will want to remove some plugins or upload the images one at a time. The only other alternative would be upgrading to a level 5 or higher VPS or a dedicated server so we can take advantage of more memory and the removal of the php memory limits. If you have any questions or concerns, please don't hesitate to contact us. We are more than happy to assist.

    Cheers, Sean H.
    Linux Systems Administrator
    cPanel Certified Technician
    HostGator.com LLC
    http://support.hostgator.com

    I told them it does it with all plugins deleted. I also told them I went to HostGators and used Quickinstall and installed their WordPress software to a sub-directory and tried upload an image and I still get the error.

    They came back and told me this.

    Unfortunately, we have been unable to reproduce this error from our end. When we've uploaded images, there is no error message shown. It sounds like there could be a network related problem possibly dropping packets causing the error.

    I send them a ping plotter report. In the mean time I used my Ipad with AT&T wireless and I get the same error.

    They mail me back.

    This appears to be an issue with a corrupt WordPress install. As after reinstalling the core files the images are now uploading without an issue for http://rickmick.com/wordpress-2/ Can you tell us how you are installing WordPress?

    I tell them how and that I am still getting the error. Here is their reply

    We are able to upload images without an issue at this time. However WordPress will give an error it appears which refreshing your browser will allow your image to appear. As you can see these files were all uploaded using the image uploader.

    We did some research and it does appear to be an issue with WordPress as there is many reports on their forums for this issue.

  16. rickmick
    Member
    Posted 1 year ago #

    From me

    I might believe that it is 3.5.1 WordPress, but I did a clean install using 3.4 WordPress that has ran on HostGator without any issues. With no plugins, added themes, and it was fresh out of the box. It will not upload and image using multi-file uploader without issues. I don't know how your hosting works, but it acts like WordPress did something to the server on my hosting site to prevent me from using multi-file uploader. It does not matter what version of WordPress I use. It is not my network because I tried it on my Ipad wireless and I was not connected to my network.

    Hello,

    Thank you for contacting HostGator. I apologize for the inconvenience you are experiencing with your WordPress. I have checked further into the issue and the images are being uploaded but WordPress is not completing the normal process. There are no apache or php errors being generated on the server. The only error is in the WordPress interface which isn't showing any details. The images show up if you view the media library despite the error message or the hang on crunching. The php.ini file in your home folder has all the maximum settings and we have already increased your rlimit to the maximum. I so apologize but for further support on this issue with WordPress you will need to contact WordPress. http://wordpress.org/support/ If you have any questions or concerns, please don't hesitate to contact us. We are more than happy to assist.

    Cheers,
    Sean H. Linux Systems Administrator
    cPanel Certified Technician
    HostGator.com LLC
    http://support.hostgator.com

    They are convenienced it is WordPress. That leaves me running my site the hard way.

  17. rickmick
    Member
    Posted 1 year ago #

    FYI--- I have cured half of the problem by going back to wordpress-3.5-RC1 and manually installing it. I can now upload an image to my post without an error using multi-file uploader. When I go to media and try uploading an image all it does is show full Crunching.. The image uploads but you don't see it until you go to the library.

    Using 3.4 and 3.5.1 I still get errors. For now I will stick with 3.5-RC1 at least I can post images to my post without a hassle.

    I hope the experts figure this one out whether it is HostGator or WordPress.

  18. rickmick
    Member
    Posted 1 year ago #

    I found the source of the problem uploading images to my site. The source came from HostGator caused by Attracta SEO. It had placed a file on my website called .fastinclude. After finding it I deleted the file and now I can upload images.

    I know I'm not the only one that is having this problem so this should help a lot of people. I have email Hostgator so they can fix the problem.

    Thank all of you for your help.

    Here is the script.

    <!-- Begin Attracta Include 2012-10-04 17:32 -->
    
    <script type='text/javascript'>
    function attracta_loadjs(url) {
    (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = url;
    var x = document.getElementsByTagName('script')[0];
    x.parentNode.insertBefore(s, x);
    })();
    }
    function attracta_shouldrun() {
    var v = ["/admin/","/adm/","/wp-admin/","/administrator/"];
    for (x in v) if(window.location.pathname.indexOf(v[x]) == 0) return false;
    return true;
    }
    function attracta_window_width() {
    if (document.body && document.body.offsetWidth) return document.body.offsetWidth;
    if (document.compatMode=='CSS1Compat' && document.documentElement && document.documentElement.offsetWidth ) return document.documentElement.offsetWidth;
    if (window.innerWidth) return window.innerWidth;
    return 0;
    }
    function attracta_window_height() {
    if (document.body && document.body.offsetHeight) return document.body.offsetHeight;
    if (document.compatMode=='CSS1Compat' && document.documentElement && document.documentElement.offsetHeight ) return document.documentElement.offsetHeight;
    if (window.innerHeight) return window.innerHeight;
    return 0;
    }
    </script>
  19. Jess
    Member
    Posted 1 year ago #

    So glad that you found the solution! Sorry I couldn't be of more help.

Topic Closed

This topic has been closed to new replies.

About this Topic