WordPress.org

Ready to get started?Download WordPress

Forums

Uploading Images Error Message (11 posts)

  1. enrique_guzman
    Member
    Posted 2 years ago #

    I get the following error when uploading/inserting images into a post: "image001" has failed to upload due to an error. Unable to create directory, Is its parent directory writable by the server?. What is frustrating is that I tried two different web hosts with 2 different databases and I get the same results with kionic web hosting and go daddy web hosting. I appreciate your suggestions.

  2. Good Guy
    Member
    Posted 2 years ago #

    Have you tried uploading it to public sites like flickr or screencast, google Docs or Microsoft SkyDrive?

    You can try dooing this to test if there is anything wrong on your own system. It is just a test I must add here.

    Alternatively, you could try uploading using FTP clients like FileZilla or something similar.

    Hope this helps.

  3. karthikskr
    Member
    Posted 2 years ago #

    Make sure the uploads folder in wp-content directory has writable permissions. This will help you in uploading your media files.

  4. enrique_guzman
    Member
    Posted 2 years ago #

    I checked the file permissions and they seem ok, therefore, my problem is not resolved yet. Also, I tried in a different computer but keep getting the same error message

  5. Good Guy
    Member
    Posted 2 years ago #

    I checked the file permissions and they seem ok, therefore, my problem is not resolved yet. Also, I tried in a different computer but keep getting the same error message

    this does not tell us whether you have tried uploading the file using third party software like filezilla?

    Alternatively, if you want something quick to test if there is something wrong with the theme then I suggest try creating a free website from this link:

    https://en.wordpress.com/signup/

    Then try uploading the image on that free website. We need to know if there is anything wrong with your own system or even how you are ttrying to upload the image.

    Please post back if you can't do this method so that somebody else can suggest something else.

    Good luck.

  6. enrique_guzman
    Member
    Posted 2 years ago #

    I tried uploading images on the link for the free website provided by you guys and it uploaded successfully, now to clarify, I'm trying to upload images/media onto my posts on my self hosted wordpress site using the media uploader and thats where I get the error.

  7. Good Guy
    Member
    Posted 2 years ago #

    I tried uploading images on the link for the free website provided by you guys and it uploaded successfully, now to clarify, I'm trying to upload images/media onto my posts on my self hosted wordpress site using the media uploader and thats where I get the error.

    OK now we know the problem is at your end i.e. on your self hosted site. Can you tell us which theme are you using and and is it downloadable free of charge from the web? We need to try it out on our machines to see what is the problem.

    I am, of course, assuming that you don't have disk quota problem. Some hosts have quotas on certain plans so I am sure you have checked this out.

  8. enrique_guzman
    Member
    Posted 2 years ago #

    I'm using the default wordpress site "Twenty Eleven 1.3" and the wordpress version I have installed is the recent one "3.3.2". Thanks, appreciate your help

  9. Good Guy
    Member
    Posted 2 years ago #

    One more test:

    Can you remame the image file to "image099" so that it looks like:

    image001 >> image099

    Then try to upload it. Ilooks like the file name image001 is already on the server and it is refusing to overwrite it.

    When you rename the file make sure you keep the same file extension. you only want to rename the main file name. So "image001.png" will become "image099.png". I have chosen the 99 number because you are unlikely to have this filename on the server.

    Let us know if this worked.

  10. enrique_guzman
    Member
    Posted 2 years ago #

    it seems I fixed it, I was reading trought the entire forum and find out that I had to create the uploads folder myself inside the wp-content folder and also I had to change the file permission from 0755 to 0777, thanks guys. Hopefully I won't have any other inconvenience.

  11. Good Guy
    Member
    Posted 2 years ago #

    Thank god you have fixed it. We can now all have a vacation on Monday (May-day in some countries!!!!!!!!)

    Good luck and keep us informed of your progress.

Topic Closed

This topic has been closed to new replies.

About this Topic