WordPress.org

Ready to get started?Download WordPress

Forums

Uploading Error - "This script was not meant to be called directly." (10 posts)

  1. wildlyluxurious
    Member
    Posted 8 years ago #

    Hi,

    I cannot get my upload to work at all....it says the following when i try to upload a file:

    "This script was not meant to be called directly."

  2. whooami
    Member
    Posted 8 years ago #

    umm.. are you attempting to call wp-admin/inline-uploading.php directly, ie, like :

    http://www.yourdomain.com/wp-admin/wp-admin/inline-uploading.php

    cuz thats the only way I can duplicate that error, and thats not how its meant to be used.

  3. wildlyluxurious
    Member
    Posted 8 years ago #

    Im just writing a post....using the Upload button? Insist that how you upload a file ?

  4. whooami
    Member
    Posted 8 years ago #

    yeap, sounds like your trying to do it the right way.

  5. wildlyluxurious
    Member
    Posted 8 years ago #

    hmmm......is it only used for image uploading?

  6. sluggo
    Member
    Posted 8 years ago #

    How large is your upload? If it's greater than 2MB, you need to increase the value of upload_max_filesize in your php.ini. And if it's greater than 8MB, you also need to increase the value of post_max_size.

  7. uncle_ed
    Member
    Posted 7 years ago #

    T'anks! I'll investigate ...... stand by .................

    ......................... checking ........................

    can't find php.ini. where might that be?

    btw, is this a big time geek app? I find user friendliness here (other than your patient guidance) daunting.

  8. samguzman
    Member
    Posted 7 years ago #

    Actually, I am getting the same error, but instead its when I try to login to the admin cp. I just installed wordpress and I tried to login like I have many times before and it gave me that error. I have no idea what it means and I know it has nothing to do with php.ini

  9. stary
    Member
    Posted 7 years ago #

    Got this message today when I wanted to upload (inline) MP4 files exceeding 8 MB (the default setting in php.ini).
    I solved by setting the previously mentioned parameters in php.ini. Many thanks!

    OS: Windows 2003
    Webserver: Apache 2.0.58
    PHP: 4.2.2

  10. Melodiefabrieknl
    Member
    Posted 7 years ago #

    some hosting services don't let you change the php.ini file directly, DreamHost for example, but they have a workaround for it which works just fine. check out http://wiki.dreamhost.com/index.php/PHP.ini

    And you can also change this on DreamHost when you're running several domains under one account; creating several .sh file and adding them all line by line to a cron job.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.