WordPress.org

Ready to get started?Download WordPress

Forums

Uploading a plugin screenshots are misplaced (6 posts)

  1. beeline
    Member
    Posted 4 years ago #

    We have recently updated our "Beeline" plugin. The readme validates ok, but the screen shots section shows the plugin's short description instead of the images themselves.

    Can't figure that out. Help?

  2. Mike Challis
    Member
    Posted 4 years ago #

  3. Mike Challis
    Member
    Posted 4 years ago #

    I converted my screenshots from jpg to gif and now they are working again.
    Why were they broken? Something needs fixing at wordpress.org

  4. beeline
    Member
    Posted 4 years ago #

    Did that. Not working.

    WordPress?! Anyone home?

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Dunno the exact problem, but I have a couple of ideas.

    1. I use PNG files. Works great. Way smaller files that way if you use IrfanView and the PNGOUT plugin to make them super-small. PNG is preferred to GIF, the only thing GIF is good for is animated images.

    2. Your filenames have capitalized extensions. GIF instead of gif. Might be a problem.

    Comparison of your plugin to one of mine which has working screenshots:

    http://plugins.svn.wordpress.org/beeline/tags/1.0.5/

    http://plugins.svn.wordpress.org/simple-facebook-connect/tags/0.18/

  6. robbyslaughter
    Member
    Posted 4 years ago #

    As of this moment, I have the same problem at:

    http://wordpress.org/extend/plugins/blogging-checklist/screenshots/

    My suspicion is that that the code which parses the README is not very robust. I think the best answer for now is just to link to your own website, though that makes things a little less elegant for people browsing the repository from inside the Admin menus on their own WP installation.

    Update: It magically fixed itself. I did try changing from JPG to PNG. Wonders.

Topic Closed

This topic has been closed to new replies.

About this Topic