WordPress.org

Ready to get started?Download WordPress

Forums

Uploading a backed up site and DB to new hosting account. (4 posts)

  1. jasonross959
    Member
    Posted 5 months ago #

    Hey guys,

    I've gotten myself into a situation here. I'm dealing with my ex-gf's website. I used to have her site and domain up on my hosting with GoDaddy. I've since transferred the domain to her GoDaddy account and had her buy a hosting plan.

    Before I cancelled my hosting, I backed up all of her website files (via filezilla) and exported her DB from phpmyadmin.

    I set up a database on her hosting account, imported the old tables, uploaded all of her websites files (wp-admin, wp-contents, etc) to her root directory, updated the wp-config and....it doesn't work.

    I'm getting this error:

    Parse error: syntax error, unexpected '.229' (T_DNUMBER) in /home/maggie22/public_html/wp-config.php on line 28

    Here is my wp-config.php:

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', ‘maggie’);
    
    /** MySQL database username */
    define('DB_USER', ‘maggie2299’);
    
    /** MySQL database password */
    define('DB_PASSWORD', ‘*********’);
    
    /** MySQL hostname */
    define('DB_HOST', ‘23.229.155.199’);
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '=O6>6LA7iL55HQC$5|q~9f,C

    seGK-6}Q&o#^91$wr?6dGc0^h5>P~uX-iU6#-zp');
    define('SECURE_AUTH_KEY', '+?S~;s+T5)6^ut7c|MfXI!Zv%uknJ(0^(+eJ(hO>pQnf

    >-Jbo?X>WPp.fLs k^@');
    define('LOGGED_IN_KEY',    ':HR%~iN6a@vIy6vXx]8N0?h.md}zYu*Pbb7@1!Fi>-E+sM/b6$f]:?o2@%CQ[Iqk');
    define('NONCE_KEY',        'c=ZI,Uau~NB0XL|>5d.{+3V$pZnqu={jc/:*e+otkb%%a^N?yT?l)_LaM]

    #Fk/H');
    define('AUTH_SALT', '}H2N7;[%B}e0~-]siL9+8e2F?1yJgFRka~$+PUFCHK>zHM4g)}2-oV4k{![Qs?m#');
    define('SECURE_AUTH_SALT', 'TE]MNB

    |xR~fn~Wd/K}jnxy-V^~4$t)mwv{/ q!n8Py*$i&L/OS,^1w0|STEHx=d');
    define('LOGGED_IN_SALT',   '[<code>YW_y8Djh*t;q%L*C:A.DC((0!k,3_Sd(3l-9Mhq{{%=P8</code>dvUr8~}5N3C<:@-o');
    define('NONCE_SALT',       'ui62((3zYn]Pu-L^JsI2u@6w_?IO9-7+g(={vSdreuo(Z.u*F7_^jKk[rS_0,-3^');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    [Moderator Note: Please post code or markup between backticks or use the code button. Or better still - use a pastebin. Your posted code may now have been permanently damaged by the forum's parser.]

    Thank you for your help!

  2. JumboClicks
    Member
    Posted 5 months ago #

    if the database is on the same computer
    you should use 'localhost'

    define( 'DB_HOST', '123.123.123.123' );

    I can't really tell but it may be because you are using curly quotes around the IP number instead of regular single quotes '

  3. Stephane_D
    Member
    Posted 6 days ago #

    I had exactly the same issue and the change of curly quotes to regular single quotes worked.
    Thanks JumboClicks !!!

  4. Mark Senff
    Member
    Posted 6 days ago #

    It's the curly quotes around all the database details:

    /** The name of the database for WordPress */
    define('DB_NAME', ‘maggie’);
    
    /** MySQL database username */
    define('DB_USER', ‘maggie2299’);
    
    /** MySQL database password */
    define('DB_PASSWORD', ‘*********’);
    
    /** MySQL hostname */
    define('DB_HOST', ‘23.229.155.199’);

    This should be:

    /** The name of the database for WordPress */
    define('DB_NAME', 'maggie');
    
    /** MySQL database username */
    define('DB_USER', 'maggie2299');
    
    /** MySQL database password */
    define('DB_PASSWORD', '*********');
    
    /** MySQL hostname */
    define('DB_HOST', '23.229.155.199');

Reply

You must log in to post.

About this Topic