WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Uploaded images show dimensions of 0x0 in 3.3 (17 posts)

  1. iamarogue
    Member
    Posted 2 years ago #

    This is a bit weird.

    I updated to 3.3 on a site that I am migrating over from an old server (I don't think this has anything to do with it, but it might). Now anytime I add pictures, I can find them, select them, and upload them just fine, but when they are fully oploaded, they say that their dimensions are 0x0, there is no thumbnail, and it seems to have a file size of 0.

    I am using Antisnews 1.9 with WordPress 3.3, using Chrome 15.0.874.121 m.

    When this first happened, I tried uploading other types of images, same problem. I disabled all of my plugins (i do have NextGen Gallery), and briefly, it started to work (I could upload images, they would show up properly). Then all of a sudden, the problem came back. I didn't do anything in between other than uploading two images, deleting a few posts and adding tags to existing posts.

    I have tried disabling all plugins, re-uploading a clean installation of WordPress, and reverting to Twenty Eleven. Even with these changes, I am still unable to upload images.

  2. iamarogue
    Member
    Posted 2 years ago #

    Oh I forgot to mention, clearing the cache also didn't work, and it is a problem whether I use the browser uploader or the new uploader (they both don't work.

  3. I updated to 3.3 on a site that I am migrating over from an old server (I don't think this has anything to do with it, but it might).

    I do :)

    Did the domain name change, or the location of WP? And if so, did you happen to search/replace the database for the old URL?

  4. iamarogue
    Member
    Posted 2 years ago #

    Yes the domain name changed. And I had a LOT of trouble importing - first the export file from PHPMyAdmin was too big so my new server wouldn't let me upload it... ah it was a long process.

    What I did:

    1. Exported my old database from phpMyAdmin (zipped) and imported using phpMyAdmin on my new server.
    2. Discovered all my content was there, not working though.
    3. Used Search & Replace plugin to change my domain name whenever it occurred. I think this broke the site even more though.
    4. Stupid me, forgot to change the site location on General Settings page. Went back to old blog, changed that, exported again, imported again.
    5. Still not working.
    6. Updated my .htaccess file! Solved the missing content problem.

    So the answer is sort of. I know how, but I guess I haven't done that since everything seemed to work after the .htaccess file was edited. I'm worried about messing up my entire site.

    Would it be safe to search/replace all references to the domain name?

  5. Used Search & Replace plugin to change my domain name whenever it occurred. I think this broke the site even more though.

    Ding. We have a winner. You should ONLY have replaced the instances in wp_posts. When you make those changes in wp_options (and wp_postmeta) you break serialization (which is a weird thing that captures the LENGTH of your URL in its values).

    If you do a search/replace on wp_postmeta only, you should be able to flip that back to the old URL without issues.

  6. iamarogue
    Member
    Posted 2 years ago #

    Hmm. I'm not convinced that's the issue, because after I used the Search & Replace, I re-imported the entire database.

    Anyways, I just tried what you said, searched for only wp_posts. Here's a screenshot: http://postimage.org/image/r16s8xvrf/ it replaced a whole bunch of them.

    Afterwards, I tried uploading a new picture, and I got the same error again. Here's a screenshot of the 0x0 uploading screen. http://postimage.org/image/cf9advjc5/

  7. BenjiSlayer
    Member
    Posted 2 years ago #

    Hello!

    I have the same problem, no error messages o scripts appeared.

    I tried to change the permissions of the folder(but they already had 777).
    And I also changed destination folder, but is the same.

    I deactivated all plugins. Even, i reinstalled the 3.3 version again (manual and automatic) and the problem continues.

  8. iamarogue
    Member
    Posted 2 years ago #

    Phew! I'm not alone. BenjiSlayer, let's compare. Have you also recently moved your site? Ipstenu seems to think this has to do with a database error.

    I've been having this problem intermittently - that is, I tried to upload an image this morning and it worked! Then I did it again and it stopped working.

    There seems to be a few image-uploading related bugs or problems. All slightly different but there are similarities. Maybe some can help you?
    http://wordpress.org/support/topic/new-images-dont-show-after-upgrade-to-33?replies=11
    http://wordpress.org/support/topic/uploading-images-to-wordpress-33?replies=9
    http://wordpress.org/support/topic/wordpress-fails-to-upload-pictures?replies=4
    http://wordpress.org/support/topic/cant-upload-media-6?replies=5

  9. BenjiSlayer
    Member
    Posted 2 years ago #

    Actually, my webhosting moved it. But only the servers.

    I got a few errors due this process, for example some folders had permisssions 664 instead of 777 (cache folders and upload folders).

    In my case isn't intermittentenly, since i upgrade i can't upload images.

    I checked the others links, in particular:

    http://wordpress.org/support/topic/uploading-images-to-wordpress-33?replies=14#post-2503351

    They said that tes with other browsers, i tested with chrome, firefox (latest version both of them) and with IE8, and nothing change...

  10. cbunting99
    Member
    Posted 2 years ago #

    You may need to check to make sure your upload directory is writable and you may need to get your host to check the permissions of your hosting directory and make sure your username, has permission to edit/upload/modify the files. Something like;

    chown --recursive username.username /var/www/html/domain.com

    wp-content usually needs to be chmodded 755 or 777 if you use plugins like super cache, it will need to write to that directory. For the image issues, you may have to chmod each subdirectory under uploads, such as uploads/2011/12

    Thats all I can think of off the top of my head. Hope this helps,
    Chris

  11. iamarogue
    Member
    Posted 2 years ago #

    Aww, crap! I can't believe it was that easy. I could have sworn that I had set permissions to 777, but apparently not.

    Thanks Chris!

  12. cbunting99
    Member
    Posted 2 years ago #

    No problem.. Glad I was able to help..

    Chris

  13. aiham_rk
    Member
    Posted 2 years ago #

    I tried to change the permissions of the folder(but they already had 777).
    And I also changed destination folder, but is the same.

    I deactivated all plugins. Even, i reinstalled the 3.3 version again (manual and automatic) and the problem continues.

    also I tried to manual install 3.2.1 and remove 3.3 but the problem still exist
    when i try wordpress on my laptop (IIS server) no problem with uploading image
    my site server using linux and i tried to change folder to 777 but no hope

  14. agiesbrecht
    Member
    Posted 2 years ago #

    I also have this problem, but at least in my case it doesn't seem to have anything to do with permissions (777 for all directories involved). I also haven't any any domain or server change.

    The only thing related that has changed is that I added a new image size via funcions.php on my theme, but I have tested removing it, and it didn't work:

    if ( function_exists( 'add_image_size' ) ) {
    	add_image_size( 'destaque', 960, 640 );
    }

    The problem appeared after upgrading to 3.3. I have upgraded to 3.3.1, yet the problem persists, both with the new and old uploader.

    One other thing: the files are being uploaded to the server; it's just that I can't see the sizes on WordPress.

    Strange thing: when I do it from my laptop (same Windows and Firefox versions, same internet connection), it works as it should. But only from it.

  15. Doug-O
    Member
    Posted 2 years ago #

    I am inserting this in every open query on this topic, as it actually solved the problem. This happens because one of the databases gets locked. You have to use PHPMyAdmin tool (available from your host most likely) to review the status of all the databases in use for your site. Select the ‘wordpressblog’ (or whatever set of databases seem appropriate) from the list at left. This brings up all the databases running on your site. The particular database that caused this problem was wp_postmeta - the status in the PHPMyAdmin window was ‘in use,’ and as our databases are small this should never be the case when you can look at them and see them in use - they should be just sitting there. Here it was locked. In the PHP MYAdmin tool, check the particular database that’s in use, then on the drop down box at the bottom select ‘repair table.’ This instantly solved my problem. Thanks to yahoo support rep!

  16. Celso Bessa
    Member
    Posted 1 year ago #

    Well, this is just a reference for anyone having this problem. Had the same problem, but for other reason.

    In My case, it was the use of a CDN Sync tool plugin that caused this and several other problems related to image processing (Regenerate Thumbnails and SMush.it plugins also stopped working) when saving.

    So, try and see if any of your plugins messes with saving files and try to disable it.

  17. Celso Bessa
    Member
    Posted 1 year ago #

    Just reposting what i wrote in another related thread:

    "Well, this is just a reference for anyone having this problem. Had the same problem, but for other reason.

    In My case, it was the use of a CDN Sync tool plugin that caused this and several other problems related to image processing (Regenerate Thumbnails and SMush.it plugins also stopped working) when saving.

    So, try and see if any of your plugins messes with saving files and try to disable it."

Topic Closed

This topic has been closed to new replies.

About this Topic