WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Uploaded images doesn't show, except on the root domain (7 posts)

  1. greatdanemaniac
    Member
    Posted 3 years ago #

    Hi!
    I've recently changed hosts, from one.com to super green hosting,and so far I'm very pleased.

    Although, earlier today I found out that I can't display my uploaded images properly. The uploading process goes fine, but on my sub-domains, the images are just blank with that "broken image" or how you describe it.

    On my root domain, I can upload images, and even change the header image (using twentyten on all my domains), but that doesn't work on my sub-domains.

    Does anybody know why this is?
    I've checked with the host in my cPanel with MIME types, and all image extensions I work with are supported. I'm using windows 7 and chrome as my web browser.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Check your uploads path in Settings/Media. Other than that, a link to your problem site might help.

  3. greatdanemaniac
    Member
    Posted 3 years ago #

    Ok, as far as I know, there isn't an option for uploads in settings/media, but I can check.

    you can check out my test site, where I have uploaded an image for this purpose... http://test.greatdanemaniac.com

    I've checked all upload paths etc for my sub-domain blogs in the network, and everything is as it should be...

    I really hate this problem! images is the least basic content of a blog...

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    There is an uploads path field in Admin/Settings/Media.

  5. greatdanemaniac
    Member
    Posted 3 years ago #

    Well, I can't find it... I know that I've seen it before, but I guess that was when I only had one site, now I use multi- sites with sub-domains and version 3.0.1.

    I'm also using cPanel with my host, and I have before, and also used sub-domains, with no trouble what so ever... I don't get why this isn't working, and none of the tips that I've received from this forum has helped me, even though it has helped others with the same problem.

    I've checked with my host as well, and they were not able to help me. all they did was move or create 2 new .htaccess files with wordpress rewrite rules...

    I'm going crazy on this one! Sorry about that...

  6. greatdanemaniac
    Member
    Posted 3 years ago #

    I solved it!

    This is what I had to put in my .htaccess file:

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    before I had a regular code, like .*^ or something like that. The numbers and letters [_0-9a-zA-Z-] did the trick, thank god!

    Thanks for replying though. Don't get that many replies to my posts here in the forum otherwise, so I thank you.

  7. gkaruppusamy
    Member
    Posted 3 years ago #

    Thank you very much greatdanemaniac. Your highlight is save me from death deadline

Topic Closed

This topic has been closed to new replies.

About this Topic