WordPress.org

Ready to get started?Download WordPress

Forums

Uploaded from local to remote host - some links & images not working (4 posts)

  1. sillysausagesally
    Member
    Posted 1 year ago #

    Hi all

    I had my wordpress site on localhost (using xammp). Yesterday I uploaded to remote host following this tutorial

    I then saved the permalinks on remote host version of wordpress. Some links and images are not working. Some images are only showing the alt text. Link in the mega menu and links in sidebar widgets, and links in the page text have not updated, they still point to localhost.

    Also, the main banner at top of the page is not showing, just text underneath.

    I am using Suffusion theme

    Site is at http://www.mftcollege.co.uk/test

    Thanks wordpress geniuses!

  2. Marco Milesi
    Member
    Posted 1 year ago #

    Did you change the URL in WordPress > Settings ?

    WordPress URL (URL) = http://www.mftcollege.co.uk/test/
    Website (URL) = http://www.mftcollege.co.uk/test/

    Everywhere you find "http://localhost/wordpress", change it to "http://www.mftcollege.co.uk/test/"

  3. sillysausagesally
    Member
    Posted 1 year ago #

    Thanks Milmor. Yes the address in Settings is correct. I refreshed the Permalinks and I changed the structure in phpmyadmin on my remote host.

    Any other ideas?

    Should I do a replace (I use Notepad ++) for localhost to the new url? If so which file do I do that in? Is it wp_config.php? Or the sql file I exported from Xammp?

    thanks!

  4. Marco Milesi
    Member
    Posted 1 year ago #

    Don't hack wp-config localhost! At least try adding these lines:
    define('WP_HOME','http://www.mftcollege.co.uk/test/');
    define('WP_SITEURL','http://www.mftcollege.co.uk/test/');

    Some months ago i had the same problem and i found the solution in PhpMyAdmin (wp_options table)...
    All the solutions can be found here: http://codex.wordpress.org/Changing_The_Site_URL

    PS. I have seen that some links in your website are broken; another step for you is to install this plugin: http://wordpress.org/extend/plugins/search-and-replace/ and replace everywhere the string http://localhost/wordpress to http://www.mftcollege.co.uk/test/. This can help you to have all the links in post/pages correct (it should definetely fix also images...)

Topic Closed

This topic has been closed to new replies.

About this Topic