WordPress.org

Ready to get started?Download WordPress

Forums

Upload works, but can't edit gallery afterwards (5 posts)

  1. texpilot
    Member
    Posted 5 years ago #

    I'm having an issue with posts with gallery short code in them. After creating a post and uploading files using the media uploader from my computer, I get a "Not found" error on file /cp_wp/wp-admin//media-upload.php. Note the double slashes in front of media-upload.php -- I can't find where the extra slash is coming from. Other than that, the path is correct.

    My .htaccess file is located in wp-admin and contains:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /cp_wp/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /cp_wp/index.php [L]
    </IfModule>
    # END WordPress

    My install is located at mydomain.com/cp_wp, so the rewrite rules above look to be correct as far as I can tell. My workflow for creating a post and uploading images for a gallery:

    New post
    Add title and text to the post
    Click insert media-images
    Select Files (flash uploader)
    Select 5 images, wait for upload/crunching
    Click "save all changes"
    In the Gallery section below, click Link Thumbnails to Attachment
    Order by Name
    Click Insert Gallery

    Thus far, everything works. The post displays when I visit the site, the gallery works (which a could of minor behaviors that differ from dev that I can't figure out, but overall it works), etc. However, if I return to the admin site and edit the post, when I click on the gallery section and click "Edit Gallery", I get the error:

    Not Found
    The requested URL /cp_wp/wp-admin//media-upload.php was not found on this server.
    Apache/1.3.41 Server at http://www.mydomain.com Port 80

    I'm at a total loss because I did not encounter this issue at all on my local development machine during testing, and I have replicated my files and settings exactly. It only occurs out at my ISP.

    Any help would be greatly appreciated. Many thanks and best regards,
    Terry

  2. texpilot
    Member
    Posted 5 years ago #

    Sorry, forgot to mention this is a fresh 2.7.1 install.

  3. texpilot
    Member
    Posted 5 years ago #

    I decided to start over with latest.tar.gz, rather than uploading all files from my dev machine. Unzipped and untarred latest.tar.gz up on my ISPs server via shell access. Went through the install, copied the Cleaner Gallery, Lightbox 2, and Get The Image plugins, went through the Settings tabs and set everything according to my dev site.

    WordPress creates the .htaccess in at mydomain.com/html/cp_wp directory (the directory where I installed WordPress), and I haven't copied it to wp-admin as I did previously after reading a post that was for v2.5.

    Problem still exists! Man am I stumped.

  4. texpilot
    Member
    Posted 5 years ago #

    My ISP claims that this is a bug in WordPress. I don't buy it because it works just fine on my local development machine.

    My ISP says I should change the following code in wp-includes/js/tinymce/plugins/wpgallery/editor_plugin.js

    From:
    tb_show('', tinymce.documentBaseURL + '/media-upload.php?post_id='+post_id+'&tab=gallery&TB_iframe=true');

    To:
    tb_show('', tinymce.documentBaseURL + 'media-upload.php?post_id='+post_id+'&tab=gallery&TB_iframe=true');

    Again, I don't understand why it works just fine on my dev machine, and at the live demo at BlueHost.com. Can anyone confirm whether this is a bug?

  5. dloose
    Member
    Posted 4 years ago #

    texpilot -

    did you ever resolve this issue? I'm encountering the same problem with WP 2.8.4

Topic Closed

This topic has been closed to new replies.

About this Topic