WordPress.org

Ready to get started?Download WordPress

Forums

upload pictures - not able to (7 posts)

  1. jochenre
    Member
    Posted 8 years ago #

    i installed wp 2 . and it works fine. but uploading of pics isnt possible.
    the mesage is: is the folder writable?
    the code on ftp is 755
    what can i do

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    It might be that your host requires permissions higher (766 / 777) but that would be a very poor host if they did.

    Try making
    wp-content/uploads
    wp-content/uploads/2006
    wp-content/uploads/2006/01
    and then see what happens ?

  3. alexw
    Member
    Posted 8 years ago #

    I have the same problem. When I try to upload pics it always says (for example): "Unable to create directory /www/htdocs/w0063e37/wp-content/uploads/2006. Is /www/htdocs/w0063e37/wp-content/uploads writable?" How can I make sure, that it is writable? Thanks for your help!

  4. petit
    Member
    Posted 8 years ago #

    With your FTP client ( or SSH if that's what you use ), you should be able to set the access rights on the wp-content and wp-content/uploads directories.
    You can relax the restrictions completely by setting permissions to 777.

    The reason is that the uploads directory must be writable by the web server ( that acts as an agent for you, the anonymous user )

    If you succeed, you may try other settings like the ones mentioned above ( increasing security a bit )

  5. alexw
    Member
    Posted 8 years ago #

    It works! Thank you very much for your help!

  6. kvalvik
    Member
    Posted 8 years ago #

    I have a similar problem. I get this error message:

    "Warning: move_uploaded_file(): SAFE MODE Restriction in effect. The script whose uid is 32009 is not allowed to access /home/webjourn/public_html/wp-content/uploads/2006/01 owned by uid 99 in /home/webjourn/public_html/wp-admin/admin-functions.php on line 1757
    The uploaded file could not be moved to ."

    Any solution out there?

  7. petit
    Member
    Posted 8 years ago #

    This seems to be due to PHP SAfe Mode restrictions set by the server owner. If you own the server yourself you can change that. Otherwise you should contact your hosting company and ask if this mode is enabled and what you can do about it.

    Here is the ( very technical ) explanation in the PHP Manual:
    http://se2.php.net/features.safe-mode

    You may also google for alternative explanations/tutorials using "php safe mode"

    Good luck!
    PS I don't know PHP myself.

Topic Closed

This topic has been closed to new replies.

About this Topic