WordPress.org

Ready to get started?Download WordPress

Forums

Upload path has disappeared for all sub sites (12 posts)

  1. Frank Warwick
    Member
    Posted 4 years ago #

    the upload path should be
    http://domain.com/wp-content/blogs.dir/4/files/2010/06/mission.jpg
    but it is now
    http://domain.com/files/2010/06/mission.jpg

    missing the 'wp-content/blogs.dir/4' ('4' being the blog account)

    can anyone help please

  2. elfin
    Moderator
    Posted 4 years ago #

    Check your FTP - you should still see a /wp-content/blogs.dir/4/ directory.

    The file location is masked by WordPress and makes it appear like it is in /files/

  3. Yep, the locations are rewritten via the htaccess file.

  4. Frank Warwick
    Member
    Posted 4 years ago #

    Hi Rich 'elfin' Pedley
    I see what you mean but when I upload an image the path is missing the full path to the individual site,

    I reinstalled wordpress and now it does upload and retrieve images but not to the individual site only to the 'files/year/month/'

    Hi Andrea_r
    I checked the htaccess and it looks fine (I am running Version 3 Multiuser)

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]

    ----------------------------

    I am Still looking for the answer

  5. Frank Warwick
    Member
    Posted 4 years ago #

    Hi Rich 'elfin' Pedley
    I see what you mean but when I upload an image the path is missing the full path to the individual site,

    I reinstalled wordpress and now it does upload and retrieve images but not to the individual site only to the 'files/year/month/'

    Hi Andrea_r
    I checked the htaccess and it looks fine (I am running Version 3 Multiuser)

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]

    ----------------------------

    I am Still looking for the answer

  6. elfin
    Moderator
    Posted 4 years ago #

    erm who am I replying to? you both have similar names and are saying the same thing!

    proof of pudding. If you add an image to a page on any of the sites - does it display correctly?

  7. link to your site?

  8. Frank Warwick
    Member
    Posted 4 years ago #

    Hi Andrea_r
    the site is http://sitemaster.com.au

  9. Frank Warwick
    Member
    Posted 4 years ago #

    Looks like I have 2 accounts here, mmm I need to fix that.

  10. elfin
    Moderator
    Posted 4 years ago #

    and a link to one of the multisites hosted on there, please.

  11. Yep, easier to troubleshoot a subsite if we know what one is. :)

  12. I reinstalled wordpress and now it does upload and retrieve images but not to the individual site only to the 'files/year/month/'

    The URL it provides to your images will be with the files folder structure. But if you go into the backend of your site (via SSH or FTP) the files SHOULD be in wp-content/blogs.dir/#/files/2010... etc.

    But. Do the images work on your site?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.