WordPress.org

Ready to get started?Download WordPress

Forums

Upload new media: Unable to create directory (26 posts)

  1. si177on
    Member
    Posted 5 years ago #

    I'm getting this error:

    Unable to create directory /home/xxx/public_html/wp-content/uploads/2009/07. Is its parent directory writable by the server?

    I know this is not something new but I've tried a few things and they still don't work:

    • set the directory permissions to 777 for wp-content/uploads
    • set "Store uploads in this folder" to wp-content/uploads
    • left "Full URL path to files" blank
    • tried unchecking "Organize my uploads into month- and year-based folders"
    • it was working fine before we changed the domain name to the production domain name. what could be wrong?

  2. ryans149
    Member
    Posted 5 years ago #

    Give "recursive" 777 permission to uploads folder. Ask your Host to do this from Shell access:

    chmod -R 777 wp-contents/uploads

  3. si177on
    Member
    Posted 5 years ago #

    Thanks for the advice but it has been set to recursive. I've used Firezilla FTP client to perform that and have double-check with my service provider. Is there some backend config files that I can go check?

  4. Shane G
    Member
    Posted 5 years ago #

    Hi,

    From the provided error message...it shows that there is a permissions issue with folder..assign 766 recursive permissions to wp-contents folder..

    Also check the path wordpress admin area -> settings -> miscellaneous settings > it should be: wp-contents/uploads rather than wp-contents/uploads/ [do not require back slash at end of the path]

    Thanks,

    Shane G.

  5. bekar09
    Member
    Posted 5 years ago #

    is it possible to create the image folder through an external script and upload an image through an image url?

  6. si177on
    Member
    Posted 5 years ago #

    Hi Shane,

    I've set the folder to 777 recursive and ensured that wp-content/uploads under Settings > Miscellaneous do not have a "/" behind.

    what else could be the problem?

    thanks,
    Simon

  7. wright21
    Member
    Posted 4 years ago #

    Having the exact same problem - using 2.8.1 - permissions set at 766 (tried all sorts of variants). WordPress will not create the uploads folder.

  8. ryans149
    Member
    Posted 4 years ago #

    apart from the permission issue and Ownership of the files (I am sure this is not the issue, because you can access ftp), there is no reason to receive this error. However, just consult your host once and see what is their opinion.

  9. Vili
    Member
    Posted 4 years ago #

    I had the same problem. What solved it for me was changing the "Store uploads in this folder" setting (in Settings->Miscellaneous) from "/wp-content/uploads" to "wp-content/uploads".

  10. cmachans
    Member
    Posted 4 years ago #

    vilimaunula ... you ROCK! tried every other suggestion for this problem, but yours worked! Thanks :)

  11. wright21
    Member
    Posted 4 years ago #

    OK - this is what worked for me. Set blog directory to 775, set WP_Content to 775, set uploads to 777. On Settings/Miscellaneous lose the / in front of wp-content/uploads AND click OFF organize by date AND track links

    Finally! Took 2 weeks of all sorts of research and combinations.

  12. aloney
    Member
    Posted 4 years ago #

    Thank you wright21 , this works for me too

  13. sergee
    Member
    Posted 4 years ago #

    If you tryed everything and upload in your wordpress still doesn't work - i have an answer for you. In short: php safe mode won't let you create files or directories if your php scripts and upload directory belongs to different users. So there are 2 possible solutions: either disable php safemode (not recommended), or change an owner of scripts and upload directory:

    cd blog_root
    chown -R apache:apache *

    Complete description available here: http://tamkovich.com/2009/09/unable-to-create-directory-wp-content-uploads-is-its-parent-directory-writable-by-the-server/ (in Russian)

  14. mjoanisse
    Member
    Posted 4 years ago #

    Thank you 'Wright21', solution also effective for myself.

    Cheers!

  15. marceshleman
    Member
    Posted 4 years ago #

    hey guys, my problem was that the uploader worked, but the thumbnail and directory weren't being created (I had no error messages, just no image) I found a very simple solution,

    settings -> misc

    make sure upload location = wp-content/uploads

    mine was /wp-content/uploads and on another there was a huge string that got inserted so just double check. Make sure there is NO " / " at beginning or end of location

    Works fine.

  16. nztrade
    Member
    Posted 4 years ago #

    thank you, wright21
    it works to me too.
    cheers

  17. bapu_prabir
    Member
    Posted 4 years ago #

    Thankyou.
    Only Changing permissions to uploads folder in wp-content to 777 worked. Permission of 'wb-content' folder remains as was default 755. I was uploading 'All in One SEO' plugin on my first ever new blog markupDesign.

    Upload folder is wp-content/uploads in new WordPress2.9 as default. So no need to remove / in uploading folder path under Miscellaneous Settings.

    Cheers..Happy Coding

    Prabir
    markupDesign

  18. HI_hooligal
    Member
    Posted 4 years ago #

    Hmm, tried the misc setting, didn't help. The leading '/var/www/vhosts/mydomain.com/httpdocs' sure doesn't look right!

    Unable to create directory /var/www/vhosts/mydomain.com/httpdocs/farm/blog/wp-content/uploads/2010/03. Is its parent directory writable by the server?

  19. Rynoa
    Member
    Posted 4 years ago #

    Hi, I have the same problems and I have already tried everything suggested in this topic but nothing worked so far.
    I noticed that my error message says:

    Unable to create directory
    D:\Inetpub\webs\mydomaincom/wp-content/uploads.

    without the dot between mydomain & com...
    if this is the problem, how can I solve it?

  20. markaid
    Member
    Posted 4 years ago #

    "it was working fine before we changed the domain name to the production domain name. what could be wrong?" I did the same thing (version 2.9.2) keeping the existing blog for the new domain but not changing the path to stored uploads. Easily fixed in Settings ( Settings->Miscellaneous) take out the old domain path "/home/olddirectory/public_html/blog/wp-content" and replace with new "/home/newdirectory/public_html/blog/wp-content"

  21. goddesskarla
    Member
    Posted 4 years ago #

    Thank you vilimaunula!

    Oddly enoughtit has been working for MONTHS.. and all of the sudden I wasn't able to load images.. i changed the LONG path to wp-content/uploads in miscellaneous and it is working!

    THANKS!!

    ~gk~

  22. thedavidbrothers
    Member
    Posted 4 years ago #

    I am having the same problem. How do I set the blog directory and change the wp-content ...I can't find those options.

    Thanks!

    .

  23. thedrewseum
    Member
    Posted 4 years ago #

    This worked for me! It's under settings, media. I don't know how mine got changed, but when I put it back to the default of wp-content/uploads, it fixed the problem!

  24. Josh
    Member
    Posted 4 years ago #

    Settings => Media?

    I don't see the option there. All I have is image size and embed options.

    I'm running 3.0 multiuser w/ subdirectories. Should I be looking somewhere else for those settings?

    Thanks!

  25. pixelnate
    Member
    Posted 4 years ago #

    @jwrobbs Try going to your settings page. In the sidebar navigation there is a link to 'media'. Click on that and you'll have the option to change it.

  26. pixelnate
    Member
    Posted 4 years ago #

    Anybody solve this? Any pointers? Sorry to be annoying on this issue, but none of the fixes are working or appropriate. Setting permissions on any directory on the web to 777 is not a solution.

Topic Closed

This topic has been closed to new replies.

About this Topic