WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upload Media Issue (6 posts)

  1. davidrlewis
    Member
    Posted 2 years ago #

    This issue is causing me headaches on multiple sites on multiple servers with different plugins and different themes.

    Running WordPress 3.1.1.

    At home I can upload pictures through the media upload fine. Not a problem.

    At work however, (and where I need to be able to use WordPress most of the time), it just hangs on the 'Crunching' stage, and eventually times out. This happens on the flash uploader and the basic browser uploader.

    It happens on work desktop computers and my personal laptop on the work network (but without any of the work security software). The very same laptop works fine for uploading on my home network.

    I can only assume it is something to do with the work firewall. But how would it block uploads yet allow logins, posts etc all to be made?

    I can take this to our IT department, however they get a bit difficult when it comes to these things, so I'd like to be make sure it is definitely being caused by the firewall, and be able to be confident in asking them what I need them to do?

    Can anyone shed any light?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    I can only assume it is something to do with the work firewall.

    Yep - you need to speak to your IT people at work.

  3. dkotter
    Member
    Posted 2 years ago #

    But how would it block uploads yet allow logins, posts etc all to be made?

    Those things involve reading and writing to the database, where as image uploads require access to the server

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    It could also be something to do with the image processing via the GD Library.

  5. davidrlewis
    Member
    Posted 2 years ago #

    Definitely not a GD Library issue because it works perfectly out with the office.

    After a bit of convincing to our IT people today we got it resolved.

    Turns out our office firewall has an option to 'Drop non-http connection on TCP port 80', which was enabled. Disabled it and bingo it works again.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Thanks for posting the "fix". That might well help someone else in the future. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic