WordPress.org

Ready to get started?Download WordPress

Forums

Upload Media - Insert Into Post Not Working for Documents (3 posts)

  1. tymartist
    Member
    Posted 3 years ago #

    Hey everyone.

    This is my first experience using WordPress as a full-fledged CMS and almost everything is going better than I could have anticipated. WordPress will definitely make our client's life easier.

    On the flip side, one bug I'm having happens when I upload a document using the "Add Media" button. The upload works just fine, I see the document in the Media Library, and it exists as a physical file.

    However, when I attempt to insert that document into my post using "Insert into post," it looks like it's going to do something - then the modal window simply closes, and nothing is inserted into the editor.

    Images work just fine, it's only documents - I've tested it with PDF, DOC, and XLS.

    Thoughts?

  2. arninc
    Member
    Posted 3 years ago #

    I get this as well. It worked fine one day then stopped working. I can upload fine and see the files in the library. I can insert to a post but when I open the post it is not there just a blank square.

  3. pmansvelder
    Member
    Posted 3 years ago #

    I have the same problem, after a clean install on Ubuntu 11.04. I have reinstalled everything a couple of times, purged the database, managed to get the site working, except for the 'insert into post' function: I get the following error message:
    win.send_to_editor is not a function @ http://dragonfire/wordpress/wp-admin/media-upload.php?type=image&tab=gallery&post_id=1:4 and a blank screen.
    The version installed is 3.0.5, the one in the 'natty narwhal' repositories.

Topic Closed

This topic has been closed to new replies.

About this Topic