WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upload Limit NOT Host/php.ini/.htaccess problem (4 posts)

  1. Brandon Davis-Shannon
    Member
    Posted 3 years ago #

    Allo all,

    I have a WordPress network installed and I'm having an issue with my upload limit. It is set at 1mb and no changes I make seem to make a difference. My host is webfaction and they have confirmed that there is no limit on their end. I have edited both my php.ini and .htaccess files (both at the same time and separately) with the appropriate code and it has not changed the settings. The host has confirmed the changes and the info for the network confirms that I should have the 10mb limit I put in. However, on the media page it still lists a 1mb limit and uploads larger than 1mb receive the usual error.

    These plugins are enabled for the network:
    Avatars
    Bad Behavior
    Enhanced Meta Widget
    Exclude Pages from Navigation
    More Privacy Options
    Multisite User Management
    My Page Order
    Page Links to
    SimpleModal Login
    Wordpress Database Backup
    Wordpress Importer

    Even on a site with no other plugins activated and a variety of themes tried, the upload limit remains the same. My guess is that one of the above plugins interferes with the upload limit. Is anyone aware of potential problems with any of the plugins? Or of any other possible aspects of the install that could be causing the problems?

    Here is a sample blank site on the network if anyone needs it: http://parenethical.com/genealogy

    Thanks,
    Brandon

  2. Brandon Davis-Shannon
    Member
    Posted 3 years ago #

    Just realized that it is a single setting under the Super Admin Settings page. I had it set to 1500 kb there, so nothing would go above it.

  3. Brandon Davis-Shannon
    Member
    Posted 3 years ago #

    Just for anyone else who has this problem:

    If you have a network, it is not enough to change the php.ini or .htaccess. You also need to alter the settings under Network Admin.

    Go to Settings and scroll down to Upload settings. There is a max upload file size section. The default appears to be 1500KB. Set it as high as you want. If you have any limits in the php.ini or .htaccess, it will use which ever value is lower. So, I set the max file size to 20000KB. Under my php.ini the limit is set to 10M, so my uploads are limited to 10M.

    Hope this helps anyone else with the same problem.

  4. YogieAnamCara
    Member
    Posted 2 years ago #

    Yes, yes, yes!!! - Thank you soooo much this solved my problem!

Topic Closed

This topic has been closed to new replies.

About this Topic